Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46723

Unable to create new Pipeline in an empty Bitbucket repo

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
    • Similar Issues:
    • Sprint:
      Blue Ocean 1.3

      Description

      Summary:
      With Blue Ocean 1.3-beta 1, I am unable to create a Pipeline in a Bitbucket repo which doesn't already contain one.

      Steps to recreate:
      1. Start with a Bitbucket repo which does not contain a Jenkinsfile. Mine looks like this:

      2. Launch Blue Ocean, and create a new Pipeline. Select your Bitbucket server (mine was already set up):

      3. Choose the project that contains the empty repo, select the empty repo, click Create Pipeline:

      4. As expected, you'll be told that there are no Jenkinsfiles in empty-empty-empty.

      5. Click the newly-created "Create Pipeline" button. You'll be taken to the next screen, which is where the failure occurs. You'll get a popup stating "Error loading Pipeline."

      6. The only option is to click "Go Back," or you can click outside the boundary of that popup. With either approach, you'll end up back at the beginning of the Pipeline Creation flow:

      7. Repeat steps 1 through 4. When you get to the final click of the flow, you'll be told that there's a naming conflict, because empty-empty-empty already exists. You'll have to choose a new name.

      8. This loop repeats itself as many times as you want. It is also creating the jobs in Jenkins, but you can only see them from Classic.

      9. As a sanity check, I made sure the credentials to my BB server "worked," insofar as I could scan the multibranch pipeline from Classic. This works:

        Attachments

        1. 172.30.0.13.har
          464 kB
        2. 172.30.0.13-bbc.har
          360 kB
        3. image-2017-09-07-10-45-23-874.png
          image-2017-09-07-10-45-23-874.png
          390 kB
        4. image-2017-09-07-10-49-22-069.png
          image-2017-09-07-10-49-22-069.png
          318 kB
        5. image-2017-09-07-10-50-23-664.png
          image-2017-09-07-10-50-23-664.png
          291 kB
        6. image-2017-09-07-10-51-34-829.png
          image-2017-09-07-10-51-34-829.png
          294 kB
        7. image-2017-09-07-10-53-03-678.png
          image-2017-09-07-10-53-03-678.png
          307 kB
        8. image-2017-09-07-10-54-07-485.png
          image-2017-09-07-10-54-07-485.png
          289 kB
        9. image-2017-09-07-10-55-24-436.png
          image-2017-09-07-10-55-24-436.png
          303 kB
        10. image-2017-09-07-11-00-19-173.png
          image-2017-09-07-11-00-19-173.png
          437 kB
        11. image-2017-09-07-11-01-30-778.png
          image-2017-09-07-11-01-30-778.png
          896 kB
        12. image-2017-09-07-11-13-43-247.png
          image-2017-09-07-11-13-43-247.png
          528 kB
        13. screenshot-1.png
          screenshot-1.png
          262 kB
        14. screenshot-2.png
          screenshot-2.png
          298 kB
        15. screenshot-3.png
          screenshot-3.png
          418 kB

          Issue Links

            Activity

            cliffmeyers Cliff Meyers added a comment -

            This was actually pretty fast and easy to do, so I went ahead and did it.

            vilacides Isa Vilacides added a comment -

            Shouldn't we create an automated test reproducing the issue to prevent this from happening in the future?

            michaelneale Michael Neale added a comment -

            Isa Vilacides yes - there is a task being worked on in parallel for that (not sure it would always pick up classpath issues though, like this). 

            cliffmeyers Cliff Meyers added a comment -

            Isa Vilacides I agree, have been concerned about the lack of coverage for Bitbucket since it shipped. I will be following up with Mic about this.

            cliffmeyers Cliff Meyers added a comment -

            Adding link to Vivek's PR.


              People

              • Assignee:
                cliffmeyers Cliff Meyers
                Reporter:
                kshultz Karl Shultz
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: