Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46901

"Waiting in queue for…" indicator shows up when the pipeline is already half finished

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      2.73.1, BO 1.2.1, ci.j.io
    • Similar Issues:

      Description

      This occurs occasionally on ci.jenkins.io with the default buildPlugin() pipeline from https://github.com/jenkins-infra/pipeline-library

      The Linux agent is available quickly, the Windows agent takes forever to come online.

      Blue Ocean tells me for quite a long time that it's waiting for the windows agent… when the Linux build in the paralle() step is already finished. Knowing this would be very useful information.

      Screen shots attached. Times are off 2 hours due to my time zone, but it shows clearly one parallel is done, but BO doesn't tell me.

        Attachments

          Issue Links

            Activity

            Hide
            jamesdumay James Dumay added a comment -

            Daniel Beck yes, its over zealous right now and we plan to replace these with JENKINS-44981

            Show
            jamesdumay James Dumay added a comment - Daniel Beck yes, its over zealous right now and we plan to replace these with JENKINS-44981

              People

              • Assignee:
                Unassigned
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: