Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47022

DropDown is loosing focus on selection of an option

    XMLWordPrintable

    Details

    • Epic Link:
    • Sprint:
      Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2, Blue Ocean 1.5 - beta 1
    • Similar Issues:

      Description

      Update: I just tested with firefox and chrome and the loose the focus in showing there as well.

      When using IE and selecting DropDown options with select it is not possible to focus the next element in the tabIndex since the focus got lost.

      Steps to reproduce:
      Either http://jenkinsci.github.io/jenkins-design-language/docs (someone may want to update the docs and maybe correct the url where deployed (linked to ) or in your local jdl storybook.

      You may need to "patch" IE and add in css height=800px to dislay div otherwise you see a too small box.

      • search for Dropdown
      • press ENTER on the selection button
      • when the selection list comes, press ENTER on any given option
      • the result is that you cannot focus the next element anymore. IE has "ADD" and lost focus

        When you use "document.activeElement" on the storybook page the iframe should be the result and in a jenkins instance NULL is the result.

        Further ESC and TAB as well are loosing focus.

      In our project I had a similar problem where IE gave focus on a element that did not exist anymore and therefore uses NULL

        Attachments

          Issue Links

            Activity

            tscherler Thorsten Scherler created issue -
            jamesdumay James Dumay made changes -
            Field Original Value New Value
            Assignee Nicolae Pascu [ nicu ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.4 - beta 1 [ 401 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.4 - beta 1 [ 401 ] Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 2 [ 401, 426 ]
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35749 [ 171790 ]
            kshultz Karl Shultz added a comment -

            Testing Notes:

            Because this is a really specific set of conditions (IE11 user, plus Blue Ocean, plus keyboard navigation), manual verification of this one, once fixed, seems appropriate.

            kshultz Karl Shultz made changes -
            Labels cloudbees-internal-steel cloudbees-internal-steel testing-notes-reviewed
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 2 [ 401, 426 ] Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2 [ 401, 416, 426 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2 [ 401, 416, 426 ] Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2, Blue Ocean 1.4 - beta 5 [ 401, 416, 426, 451 ]
            nicu Nicolae Pascu made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            vivek Vivek Pandey made changes -
            Rank Ranked lower
            vivek Vivek Pandey made changes -
            Sprint Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2, Blue Ocean 1.4 - beta 5 [ 401, 416, 426, 451 ] Blue Ocean 1.4 - beta 1, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2, Blue Ocean 1.5 - beta 1 [ 401, 416, 426, 456 ]
            vivek Vivek Pandey made changes -
            Rank Ranked higher
            nicu Nicolae Pascu made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            nicu Nicolae Pascu made changes -
            Remote Link This issue links to "#1647 (Web Link)" [ 20026 ]
            nicu Nicolae Pascu made changes -
            Status In Review [ 10005 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            tscherler Thorsten Scherler made changes -
            Summary DropDown IE is loosing focus on selection of an option DropDown is loosing focus on selection of an option
            tscherler Thorsten Scherler made changes -
            Description When using IE and selecting DropDown options with select it is not possible to focus the next element in the tabIndex since the focus got lost.

            Steps to reproduce:
            Either http://jenkinsci.github.io/jenkins-design-language/docs (someone may want to update the docs and maybe correct the url where deployed (linked to ) or in your local jdl storybook.

            You may need to "patch" IE and add in css height=800px to dislay div otherwise you see a too small box.
            * search for Dropdown
            * press ENTER on the selection button
            * when the selection list comes, press ENTER on any given option
            * the result is that you cannot focus the next element anymore. IE has "ADD" and lost focus

            When you use "document.activeElement" on the storybook page the iframe should be the result and in a jenkins instance NULL is the result.

            Further ESC and TAB as well are loosing focus.

            In our project I had a similar problem where IE gave focus on a element that did not exist anymore and therefore uses NULL
            Update: I just tested with firefox and chrome and the loose the focus in showing there as well.

            When using IE and selecting DropDown options with select it is not possible to focus the next element in the tabIndex since the focus got lost.

            Steps to reproduce:
            Either http://jenkinsci.github.io/jenkins-design-language/docs (someone may want to update the docs and maybe correct the url where deployed (linked to ) or in your local jdl storybook.

            You may need to "patch" IE and add in css height=800px to dislay div otherwise you see a too small box.
            * search for Dropdown
            * press ENTER on the selection button
            * when the selection list comes, press ENTER on any given option
            * the result is that you cannot focus the next element anymore. IE has "ADD" and lost focus

            When you use "document.activeElement" on the storybook page the iframe should be the result and in a jenkins instance NULL is the result.

            Further ESC and TAB as well are loosing focus.

            In our project I had a similar problem where IE gave focus on a element that did not exist anymore and therefore uses NULL
            tscherler Thorsten Scherler made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            tscherler Thorsten Scherler added a comment -

            I just tested with firefox and chrome and the loose the focus in showing there as well.

            tscherler Thorsten Scherler added a comment -

            Karl Shultz regarding testing notes I just found out that it applies to any browser. I further think an unit test should be covering the code change.

            tscherler Thorsten Scherler made changes -
            Attachment animated.gif [ 41409 ]
            tscherler Thorsten Scherler added a comment -

            shows:

            • select dropdown with mose
            • select an option
            • hit enter again
            • nothing happens because the button lost focus
            • you have to press TAB to get focus again
            alobato Alvaro Lobato made changes -
            Assignee Nicolae Pascu [ nicu ] Alvaro Lobato [ alobato ]
            alobato Alvaro Lobato made changes -
            Assignee Alvaro Lobato [ alobato ] Nicolae Pascu [ nicu ]
            alobato Alvaro Lobato added a comment -

            Vivek Pandey can we backport this to 1.4.x ?

            nicu Nicolae Pascu made changes -
            Status Reopened [ 4 ] In Progress [ 3 ]
            nicu Nicolae Pascu made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            nicu Nicolae Pascu made changes -
            Status In Review [ 10005 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            vivek Vivek Pandey added a comment -

            Alvaro Lobato Sorry, somehow I missed it. PR is opened, https://github.com/jenkinsci/blueocean-plugin/pull/1660 for back port. I should be able to cut 1.4.2 release today after its merged.

            vivek Vivek Pandey made changes -
            Remote Link This issue links to "Page (Jenkins Wiki)" [ 20095 ]
            vivek Vivek Pandey added a comment -

            Alvaro Lobato Ported and 1.4.2 released.


              People

              • Assignee:
                nicu Nicolae Pascu
                Reporter:
                tscherler Thorsten Scherler
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: