Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47056

nested JNLPLauncher settings ignored

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 2.73.1
      slave-setup plugin 1.10
    • Similar Issues:

      Description

      When using the JNLPLauncher nested inside of a DelegatingComputerLauncher (from slave-setup plugin to start/stop instances on demand), settings such as tunnel, vmargs, and RemotingWorkDirSettings are not reflected in the provided slave-agent.jnlp.

      The problem is simply that the slave-jnlp.jar.jelly does not handle nested launchers.
      https://github.com/jenkinsci/jenkins/blob/39dfa055b0e3bcf3a0fdb1f12c0de9673ab8581c/core/src/main/java/hudson/slaves/SlaveComputer.java#L673-L676
      https://github.com/jenkinsci/jenkins/blob/39dfa055b0e3bcf3a0fdb1f12c0de9673ab8581c/core/src/main/resources/hudson/slaves/SlaveComputer/slave-agent.jnlp.jelly#L62-L84
      It seems that this doesn't result in an error because field accesses in the jelly script are dynamically typed.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Martin Nowak
          Path:
          core/src/main/java/hudson/slaves/SlaveComputer.java
          core/src/main/resources/hudson/slaves/SlaveComputer/slave-agent.jnlp.jelly
          test/src/test/java/hudson/slaves/JNLPLauncherTest.java
          http://jenkins-ci.org/commit/jenkins/257cc238fb89843531b72d387c78b6851d9d1f0c
          Log:
          JENKINS-47056 nested JNLPLauncher settings ignored

          • fixed by stripping off DelegatedComputerLaunchers and
            ComputerLauncherFilters when rendering slave-agent.jnlp
          danielbeck Daniel Beck added a comment -

          Fixed towards 2.83.


            People

            • Assignee:
              dawg Martin Nowak
              Reporter:
              dawg Martin Nowak
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: