Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47088

Unable to deploy ear file using weblogic deployer plugin

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      OS: OEL 6.8 64 bit
      Jenkins version: 2.73.1
      Weblogic plugin Version: 4.1
      Java Version: 1.8
    • Similar Issues:

      Description

      HI Support,

      Unable to deploy ear file on weblogic.

      Configured job following this url: https://wiki.jenkins.io/display/JENKINS/WebLogic+Deployer+Plugin#WebLogicDeployerPlugin-Authenticationmode.

      I've taken screen shots of job and other configuration related settings.

       

      Please look into this as early as possible.

      weblogic plugin job conf.docx

        Attachments

          Activity

          Hide
          raphc Raphael CHAUMIER added a comment - - edited

          Hi,

          Did you try to execute java command outside of jenkins (e.g /my/jdk/bin/java -cp /path/to/weblogic.jar weblogic.Deployer ....)? Is the jdk compatible wirth your weblogic.jar version ?

           

           

           

          Show
          raphc Raphael CHAUMIER added a comment - - edited Hi, Did you try to execute java command outside of jenkins (e.g /my/jdk/bin/java -cp /path/to/weblogic.jar weblogic.Deployer ....)? Is the jdk compatible wirth your weblogic.jar version ?      
          Hide
          nagesh Nagesh Rapeti added a comment -

          Hello...
          I've tried that as well but same error.
          As per documentation of weblogic I see weblogic 12.x is compatible with JDK8.
          You suspect mostly it might be due to in-compatibility of jdk with weblogic?

          Show
          nagesh Nagesh Rapeti added a comment - Hello... I've tried that as well but same error. As per documentation of weblogic I see weblogic 12.x is compatible with JDK8. You suspect mostly it might be due to in-compatibility of jdk with weblogic?
          Hide
          raphc Raphael CHAUMIER added a comment - - edited

          Hi,

          If the command '/my/jdk/bin/java -cp /path/to/weblogic.jar weblogic.Deployer ....' failed with a jdk8 I guess the issue comes from the jdk version. Did you try the same command with jdk7/6 and send me the output? 

          Tell me if you want a detailed command.

           Another thing. What is the size of your weblogic.jar ?

          Regards,

          Show
          raphc Raphael CHAUMIER added a comment - - edited Hi, If the command '/my/jdk/bin/java -cp /path/to/weblogic.jar weblogic.Deployer ....' failed with a jdk8 I guess the issue comes from the jdk version. Did you try the same command with jdk7/6 and send me the output?  Tell me if you want a detailed command.  Another thing. What is the size of your weblogic.jar ? Regards,
          Hide
          nagesh Nagesh Rapeti added a comment -

          HI..

          I've installed JAVA 8 only in support of latest Jenkins stable version as per documentation during installation. Please share detailed command or notes I'll give a try on other servers where I have Java6.

          weblogic.jar size is 8K
          wlthint3client.jar size is 7.2M

          Show
          nagesh Nagesh Rapeti added a comment - HI.. I've installed JAVA 8 only in support of latest Jenkins stable version as per documentation during installation. Please share detailed command or notes I'll give a try on other servers where I have Java6. weblogic.jar size is 8K wlthint3client.jar size is 7.2M
          Hide
          raphc Raphael CHAUMIER added a comment -

          Hi Nagesh Rapeti

          Sorry for my late response. A user of the plugin suggests :

                • WORK AROUND for WebLogic 12.2.x ****

          Just generate and use a wlfullclient-10.3.6.jarwith that I can deploy without any problem onto our WebLogic Server Version: 12.2.1.1.0.

           

          You can try this.

          Show
          raphc Raphael CHAUMIER added a comment - Hi Nagesh Rapeti Sorry for my late response. A user of the plugin suggests : WORK AROUND for WebLogic 12.2.x **** Just generate and use a  wlfullclient-10.3.6.jar ,  with that I can deploy without any problem onto our WebLogic Server Version: 12.2.1.1.0 .   You can try this.

            People

            • Assignee:
              raphc Raphael CHAUMIER
              Reporter:
              nagesh Nagesh Rapeti
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: