Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47091

Multibranch pipeline does not build GitHub pull requests destined for single branch

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: scm-api-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      I have configured a multibranch job to only find a single branch (because that's what I want). Really, the only reason I'm using multi-branch at all is for pull request functionality in pipelines.

      Unfortunately, multi-branch does not appear to detect pull requests to master. Maybe because of the branch specifier? I don't consider this working as designed. The intent here is to build pull requests destined for the master branch regardless of what the branch name might be.

      I have attached a sample config.xml, a screenshot, and the indexing log from the multibranch job. Please see environment for master and plugin versions.

        Attachments

          Activity

          sag47 Sam Gleske added a comment -

          It just simplifies bash scripting. It's not something that needs to be included in this plugin. I was able to update my scripts since you pointed that out to me. https://github.com/samrocketman/jervis/commit/315c20eb5e2a4ec8e468f0dac3534282ff04a4f0

          sag47 Sam Gleske added a comment -

          Stephen Connolly I went ahead and documented this in the plugin wiki page. https://wiki.jenkins.io/display/JENKINS/SCM+Branch+PR+Filter+Plugin

          stephenconnolly Stephen Connolly added a comment -

          Sam Gleske I suspect Andrew Bayer might be able to advise you on better examples of testing for PRs to provide on your Wiki page. Certainly there is a better way for declarative style... but I also think that your non-declarative style example is over-egged

          sag47 Sam Gleske added a comment -

          Feel free to update it; it's a wiki

          sag47 Sam Gleske added a comment -

          This issue has been resolved with the creation of a new plugin: https://wiki.jenkins.io/display/JENKINS/SCM+Filter+Branch+PR+Plugin


            People

            • Assignee:
              sag47 Sam Gleske
              Reporter:
              sag47 Sam Gleske
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: