Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4752

1.331 fails to load some projects

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:
      Show 5 results

      Description

      After upgrading from 1.330 to 1.331, some projects fail to load. Reverting to
      1.330 makes them reappear.

      I have several kinds stack traces in the log, but they all have a
      ClassCastException:

      • ConversionException with DiskUsageProperty
        hudson.util.IOException2: Unable to read
        /usr/local/web/.hudson/jobs/project1/config.xml
        at hudson.XmlFile.read(XmlFile.java:130)
        at hudson.model.Items.load(Items.java:106)
        at hudson.model.Hudson$9.call(Hudson.java:2011)
        at hudson.model.Hudson$9.call(Hudson.java:2004)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
        Caused by: com.thoughtworks.xstream.converters.ConversionException:
        com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
        java.lang.ref.WeakReference :
        com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
        java.lang.ref.WeakReference
            • Debugging information ----
              message :
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              cause-exception : java.lang.ClassCastException
              cause-message :
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              class : hudson.model.FreeStyleProject
              required-type : hudson.util.CopyOnWriteList
              path :
              /project/properties/hudson.plugins.disk_usage.DiskUsageProperty
              line number : 10
              -------------------------------
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              hudson.util.RobustReflectionConverter.unmarshallField(RobustReflectionConverter.java:261)
              at
              hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:221)
              at
              hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:172)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
              at
              com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:923)
              at hudson.util.XStream2.unmarshal(XStream2.java:70)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:909)
              at com.thoughtworks.xstream.XStream.fromXML(XStream.java:853)
              at hudson.XmlFile.read(XmlFile.java:126)
              ... 8 more
              Caused by: java.lang.ClassCastException:
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              at
              com.thoughtworks.xstream.mapper.CachingMapper.realClass(CachingMapper.java:45)
              at
              com.thoughtworks.xstream.core.util.HierarchicalStreams.readClassType(HierarchicalStreams.java:29)
              at
              com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:70)
              at
              hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:184)
              at
              hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:163)
              at hudson.util.XStream2$AssociatedConverterImpl.unmarshal(XStream2.java:157)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              ... 25 more
      • ConversionException with MonitorPublisher
        hudson.util.IOException2: Unable to read
        /usr/local/web/.hudson/jobs/project2/config.xml
        at hudson.XmlFile.read(XmlFile.java:130)
        at hudson.model.Items.load(Items.java:106)
        at hudson.model.Hudson$9.call(Hudson.java:2011)
        at hudson.model.Hudson$9.call(Hudson.java:2004)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
        Caused by: com.thoughtworks.xstream.converters.ConversionException:
        com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
        java.lang.ref.WeakReference :
        com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
        java.lang.ref.WeakReference
            • Debugging information ----
              message :
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              cause-exception : java.lang.ClassCastException
              cause-message :
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              class : hudson.maven.MavenModuleSet
              required-type : hudson.util.DescribableList
              path :
              /maven2-moduleset/publishers/hudson.plugins.statusmonitor.MonitorPublisher
              line number : 120
              -------------------------------
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              hudson.util.RobustReflectionConverter.unmarshallField(RobustReflectionConverter.java:261)
              at
              hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:221)
              at
              hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:172)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
              at
              com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:923)
              at hudson.util.XStream2.unmarshal(XStream2.java:70)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:909)
              at com.thoughtworks.xstream.XStream.fromXML(XStream.java:853)
              at hudson.XmlFile.read(XmlFile.java:126)
              ... 8 more
              Caused by: java.lang.ClassCastException:
              com.thoughtworks.xstream.mapper.CannotResolveClassException cannot be cast to
              java.lang.ref.WeakReference
              at
              com.thoughtworks.xstream.mapper.CachingMapper.realClass(CachingMapper.java:45)
              at
              com.thoughtworks.xstream.core.util.HierarchicalStreams.readClassType(HierarchicalStreams.java:29)
              at
              com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:70)
              at
              hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:184)
              at
              hudson.util.DescribableList$ConverterImpl.unmarshal(DescribableList.java:312)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              ... 25 more
      • shorter ConversionException on MonitorPublisher
        hudson.util.IOException2: Unable to read
        /usr/local/web/.hudson/jobs/project3/config.xml
        at hudson.XmlFile.read(XmlFile.java:130)
        at hudson.model.Items.load(Items.java:106)
        at hudson.model.Hudson$9.call(Hudson.java:2011)
        at hudson.model.Hudson$9.call(Hudson.java:2004)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at
        java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
        Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
            • Debugging information ----
              cause-exception : java.lang.ClassCastException
              cause-message : null
              class : hudson.maven.MavenModuleSet
              required-type : hudson.util.DescribableList
              path :
              /maven2-moduleset/publishers/hudson.plugins.statusmonitor.MonitorPublisher
              line number : 68
              -------------------------------
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              hudson.util.RobustReflectionConverter.unmarshallField(RobustReflectionConverter.java:261)
              at
              hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:221)
              at
              hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:172)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at
              com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at
              com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
              at
              com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:923)
              at hudson.util.XStream2.unmarshal(XStream2.java:70)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:909)
              at com.thoughtworks.xstream.XStream.fromXML(XStream.java:853)
              at hudson.XmlFile.read(XmlFile.java:126)
              ... 8 more
              Caused by: java.lang.ClassCastException

        Attachments

          Activity

          mindless Alan Harder added a comment -

          can you post the config.xml for one/some of these jobs, and your list of plugin?

          pavageau pavageau added a comment -

          Created an attachment (id=981)
          .hudson/jobs/project1/config.xml

          pavageau pavageau added a comment -

          Created an attachment (id=982)
          .hudson/jobs/project2/config.xml

          pavageau pavageau added a comment -

          The installed plugins are:
          nabaztag 1.6
          Hudson Emma plugin 1.10
          Hudson Sectioned View Plugin 1.5 (disabled)
          Hudson Radiator View Plugin 1.2 (disabled)
          Hudson FindBugs Plug-in 3.13
          Hudson Sonar plugin 1.1 (disabled)
          Hudson Cobertura plugin 0.8.9
          Hudson SLOCCount Plug-in 1.3 (disabled)
          Hudson SSH Slaves plugin 0.8
          Hudson promoted builds plugin 1.5 (disabled)
          Hudson Support Subscription Notification Plugin 1.1
          Hudson Status Monitor 1.1 (disabled)
          Hudson IRC Plugin 1.8-SNAPSHOT (private)
          Hudson Task Scanner Plugin- 3.13
          Hudson Warnings Plug-in 2.14
          Hudson Violations plugin 0.7.4
          Hudson Locks and Latches plugin 0.4
          TuxDroid Plugin 1.5 (disabled)
          Hudson Duplicate Code Scanner Plug-in 1.13
          Hudson Dependency Analyzer Plugin 0.4
          Hudson disk-usage plugin 0.9 (disabled)
          Green Balls 1.4
          Hudson build timeout plugin 1.5
          Hudson Continuous Integration game 1.15
          Hudson PMD Plug-in 2.13
          Hudson Checkstyle Plug-in 2.14
          Maven Integration plugin 1.331
          Hudson Subversion Plug-in 1.7
          Hudson JIRA plugin 1.16
          Change Log History 1.1
          Hudson M2 Extra Steps Plugin 1.1.2

          natacado natacado added a comment -

          I have the same problem; downgrading to 1.330 fixed it for me as well. My plugin
          list, if it's any help:

          Hudson batch task plugin 1.8
          Hudson Warnings Plug-in 2.14
          SSH Slaves plugin 0.7
          Hudson GIT plugin 0.7.3
          Hudson description setter plugin 1.4
          Hudson Subversion Plug-in 1.7
          Hudson build timeout plugin 1.5
          Hudson Cobertura plugin 0.8.9
          Hudson S3 publisher plugin 0.0.1-SNAPSHOT (private-07/10/2009...)
          Hudson SLOCCount Plug-in 1.3
          Hudson Email Extension Plugin 2.2.1
          Hudson Plot plugin 1.2
          Maven Integration plugin 1.330 (this may have changed since downgrading...?)
          Hudson Xvnc plugin 1.7
          Hudson Violations plugin 0.7.4
          Hudson Rake plugin 1.6.2
          Hudson Support Subscription Notification Plugin 1.1
          Hudson ruby metrics plugin 1.3
          Hudson IRC Plugin 1.7
          Hudson Ruby Plugin 1.1
          Twitter plugin 0.4

          natacado natacado added a comment -

          Adding myself to cc list

          kohsuke Kohsuke Kawaguchi added a comment -

          Reproduced and confirmed to be the problem in a change in XStream.

          kohsuke Kohsuke Kawaguchi added a comment -
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          branches/rc/core/pom.xml
          http://fisheye4.cenqua.com/changelog/hudson/?cs=23422
          Log:
          [FIXED JENKINS-4752] integrated the new version of XStream

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=23423
          Log:
          JENKINS-4752 Fix integrated toward 1.332, out of cycle.

          el_schalo Alexander Schäl added a comment -

          I discovered a very similar error by updating from Jenkins v1.538 to the current Jenkins v2.8:

          Jun 09, 2016 9:25:42 AM SEVERE jenkins.InitReactorRunner$1 onTaskFailed
          Failed Loading job konf_uss_afe
          java.io.IOException: Unable to read /app/udg/seu-data/jenkins/jobs/konf_uss_afe/config.xml
          	at hudson.XmlFile.read(XmlFile.java:144)
          	at hudson.model.Items.load(Items.java:332)
          	at jenkins.model.Jenkins$17.run(Jenkins.java:2824)
          	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
          	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
          	at jenkins.model.Jenkins$7.runTask(Jenkins.java:999)
          	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
          	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          	at java.lang.Thread.run(Thread.java:745)
          Caused by: com.thoughtworks.xstream.mapper.CannotResolveClassException: maven2-moduleset
          	at com.thoughtworks.xstream.mapper.DefaultMapper.realClass(DefaultMapper.java:79)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.DynamicProxyMapper.realClass(DynamicProxyMapper.java:55)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.PackageAliasingMapper.realClass(PackageAliasingMapper.java:88)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.ClassAliasingMapper.realClass(ClassAliasingMapper.java:79)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.ArrayMapper.realClass(ArrayMapper.java:74)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.SecurityMapper.realClass(SecurityMapper.java:71)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at hudson.util.XStream2$CompatibilityMapper.realClass(XStream2.java:282)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at hudson.util.xstream.MapperDelegate.realClass(MapperDelegate.java:43)
          	at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:30)
          	at com.thoughtworks.xstream.mapper.CachingMapper.realClass(CachingMapper.java:48)
          	at com.thoughtworks.xstream.core.util.HierarchicalStreams.readClassType(HierarchicalStreams.java:29)
          	at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:133)
          	at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
          	at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1189)
          	at hudson.util.XStream2.unmarshal(XStream2.java:114)
          	at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1173)
          	at com.thoughtworks.xstream.XStream.fromXML(XStream.java:1053)
          	at hudson.XmlFile.read(XmlFile.java:142)
          	... 10 more
          

          So what to do? This issue is marked as fixed...

          el_schalo Alexander Schäl added a comment -

          ...and I am using the latest Maven Project Plugin v2.13

          el_schalo Alexander Schäl added a comment -

          Update

          The solution as found at https://java.net/projects/hudson/lists/users/archive/2010-11/message/343 was:

          physically delete the maven2 plugin directory and hpi file, restart

          All jobs back


            People

            • Assignee:
              Unassigned
              Reporter:
              pavageau pavageau
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: