Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47644

Jenkins Remote API - Queue API returning 404 (wasn't before)


    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
    • Environment:
    • Similar Issues:


      This may be related to JENKINS-27256.

      We use the remote API to trigger a build. We then get the queue ID from the response of said trigger call and then query the queue API to determine the build number of the created build.

      This worked perfectly until yesterday (2017-10-24) when calls to the queue API started returning a 404. I think on this day we also updated Jenkins as we ran our Ansible playbook at our server, which starts with an `apt-get update && apt-get upgrade`.

      Code execution wise, our script is written in Node.js and we're using the "jenkins-api" package as an API client. We call `jenkins.build_with_params()`, and then immediately after we get a response we hit `jenkins.queue_item()` until we find "executable" in the data. Under the hood, the 404 is coming from "/jenkins/queue/item/<ID>/api/json". Calling the specific URL with a small delay yields the same result.

      Apologies I don't have anymore information than this as I'm not entirely sure what to provide.




            • Assignee:
              stephenmelrose Steve Melrose
            • Votes:
              0 Vote for this issue
              3 Start watching this issue


              • Created: