Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47673

Current BO Master forces third party bo based plugins to use the exact versions of npm deps

    Details

    • Similar Issues:
    • Epic Link:
    • Sprint:
      Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 2

      Description

      Since the move to hpi based jdl et. al. custom plugins are forced to sync any given dependency that is coming from BO in your plugin package.json so that you use the *exact* version as BO does.

      If not you get blank screen and some error of "0 of undefined" and then you see e.g. "react-router" involved so you need to look into your version and theirs of "react-router".

      Once you have it, you have to keep the dependency of BO on your watch to adopt when they do.

      Prior to the change the dep resolving did neither worked correctly in returning you the version BO uses and not the one you requested but at least in 90% of the cases the plugin would have still worked.

      The problem here as I see it, is it forces plugin developer to release plugins on a fixed BO version and every time BO does a new release, meaning keeping backward compatibility is becoming impossible.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kzantow Keith Zantow
                Reporter:
                tscherler Thorsten Scherler
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: