Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47977

Jenkins build fails with Root directory not writable: /usr/share/tomcat/.jenkins/cache/jars message

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
    • Environment:
      Jenkins ver. 2.73.2
    • Similar Issues:
    • Released As:
      Remoting 3.28

      Description

      Jenkins build fails with  There seems to be a similar issue 

      https://issues.jenkins-ci.org/browse/JENKINS-18578  The issue is marked as resolved. But we are still having a problem. The log is attached. 

        Attachments

          Issue Links

            Activity

            allas Alla Sapozhnikova created issue -
            danielbeck Daniel Beck added a comment -

            Oleg Nenashev is this a remoting issue?

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Component/s remoting [ 15489 ]
            oleg_nenashev Oleg Nenashev added a comment - - edited

            Daniel Beck it is, also a Maven issue (CC Arnaud Héritier).

            Just to clarify, the issues happens, because the master acts as an agent in master<=>Maven communications when the Maven build starts. Remoting since 3.7 tries to initialize a default JAR cache and not surprisingly fails when you run the master in a Tomcat container.

            It is actually similar to JENKINS-45755, likely a leftover. I will need to verify it manually, but likely picking a default cache in Launcher was a bad idea.

            It would be also great to update Maven plugin to use less ancient Remoting APIs

            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            aheritier Arnaud Héritier added a comment -

            Show
            aheritier Arnaud Héritier added a comment -
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-45755 [ JENKINS-45755 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev added a comment -

            I do not anticipate to get any Remoting maintenance time in foreseeable future, so I have decided to unassign myself from this ticket. Sorry about this regression. It should be a newbie-friendly ticket, and everybody is welcome to contribute.

            oleg_nenashev Oleg Nenashev made changes -
            Labels regression
            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            jthompson Jeff Thompson added a comment -

            This will be picked up by a Jenkins weekly build soon.

            jthompson Jeff Thompson made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            Released As Remoting 3.28

              People

              • Assignee:
                Unassigned
                Reporter:
                allas Alla Sapozhnikova
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: