Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48027

Blue Ocean dashboard showing no Pipelines

    XMLWordPrintable

    Details

    • Epic Link:
    • Sprint:
      Blue Ocean 1.4 - beta 3, Blue Ocean 1.5 - beta 2
    • Similar Issues:

      Description

      Hi,

      I found out that when I use "@" in my branch name, the request will get 404 and pipeline info won't show up.

       

       

       

        Attachments

        1. 1.png
          1.png
          114 kB
        2. 2.png
          2.png
          54 kB
        3. 3.png
          3.png
          56 kB
        4. image-2017-11-15-21-03-10-362.png
          image-2017-11-15-21-03-10-362.png
          32 kB
        5. screenshot-1.png
          screenshot-1.png
          523 kB
        6. screenshot-2.png
          screenshot-2.png
          348 kB
        7. screenshot-3.png
          screenshot-3.png
          295 kB
        8. screenshot-4.png
          screenshot-4.png
          365 kB

          Activity

          steven_chen chen po yu created issue -
          jamesdumay James Dumay added a comment -

          chen po yu could you give us some reproduction instructions? Sadly things like this are dependant on the kind of job being shown.

          steven_chen chen po yu added a comment -

          James Dumay, what you need is create a multi-branch project, and use a @ in branch name, such as "chen@test-blue-ocean".

          You will see nothing showing up in blue ocean.

          jamesdumay James Dumay made changes -
          Field Original Value New Value
          Assignee James Dumay [ jamesdumay ]
          jamesdumay James Dumay made changes -
          Sprint Blue Ocean 1.4 - beta 3 [ 416 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-1.png [ 40662 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-2.png [ 40663 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-3.png [ 40664 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-4.png [ 40665 ]
          kshultz Karl Shultz added a comment -

          chen po yu, I've got two sets of questions for you.

          First, are you acessing Jenkins from behind a proxy? If you are, that might explain some of the issues you're experiencing. In the Blue Ocean wiki, there are some suggestions to work around potential issues caused by running behind a proxy. I'll paste them here:

          In some cases proxies can rewrite URIs that have encoding in them and break web apps.

          • For apache - please follow this guide very carefully, especially the bit about nocanon
          • For nginx - please see this. Generally if you use proxy_pass directly to the Jenkins port, you are ok, otherwise see this.

          Let us know, and thanks.

          Second, when you say "blank," do you mean that the entire Blue Ocean screen is blank? Or that the screens for this particular multibranch project are blank?

          Here's why I ask. I've added two branches with @ symbols in their names to my Jenkins instance. One is to an existing multibranch project that I already had set up in Jenkins. The second was a new repository, where I'd already created a branch name with @ in it, but had not yet added it to Jenkins. Neither of these have broken Blue Ocean. Here's the existing one, with the branch name containing a @:

          Here's the second one. I ended up creating a Jenkinsfile in master first, and doing a push. Then I checked out the karl@branch branch, pulled master, and did a push to my remote, so that they ended up with the same Jenkinsfile. That's working as well:

          The Dashboard page is working as well. Here, I've filtered down to only the project in question:

          And here I'm not filtering on anything at all:

          Let us know. I'm running Blue Ocean 1.3.4, for what it's worth, which isn't anything terribly experimental or cutting edge.

          steven_chen chen po yu made changes -
          Attachment 1.png [ 40670 ]
          steven_chen chen po yu made changes -
          Attachment 2.png [ 40671 ]
          steven_chen chen po yu made changes -
          Attachment 3.png [ 40672 ]
          steven_chen chen po yu added a comment -

          Hey,

          I have got some screenshot here.

          At the dashboard page is working well as you said.

          but when I cliick on for example steven@test-web-endpoint to see what failed, I got a blank page.

          I think the correct page look like would be something like this? (master branch for example)

           

          I have upgrade to the latest Blue Ocean & Jenkins.

          Hope this will help.

          kshultz Karl Shultz added a comment -

          chen po yu - are you accessing Jenkins from behind a proxy server?

          steven_chen chen po yu added a comment -

          No

          jamesdumay James Dumay made changes -
          Sprint Blue Ocean 1.4 - beta 3 [ 416 ] Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 5 [ 416, 451 ]
          vivek Vivek Pandey made changes -
          Sprint Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 5 [ 416, 451 ] Blue Ocean 1.4 - beta 3, Blue Ocean 1.5 - beta 1 [ 416, 456 ]
          vivek Vivek Pandey made changes -
          Rank Ranked higher
          jamesdumay James Dumay made changes -
          Assignee James Dumay [ jamesdumay ]
          vivek Vivek Pandey added a comment -

          Looks like its an issue when '@' is there in branch name.

          vivek Vivek Pandey made changes -
          Assignee Ivan Meredith [ imeredith ]
          vivek Vivek Pandey added a comment -

          Ivan Meredith I verified, this indeed is a bug.

          To reproduce, create a git branch with @ symbol in the branch name, for example: bug@1234 . When a pipeline is created, clicking on activity screen on branch name 'bug@1234' will result in to blank run details page.

          I think its same branch name encoding bug, in this case its happening because frontend double encodes branch name using encodeURIComponent() but on Jenkins Util.rawEncode() doesn't encode @ symbol. 

          https://github.com/jenkinsci/jenkins/blob/e798f64854be85141ab7ba610c3a8ee0b093f36b/core/src/main/java/hudson/Util.java#L1042

           

          vivek Vivek Pandey made changes -
          Sprint Blue Ocean 1.4 - beta 3, Blue Ocean 1.5 - beta 1 [ 416, 456 ] Blue Ocean 1.4 - beta 3, Blue Ocean 1.5 - beta 2 [ 416, 481 ]
          vivek Vivek Pandey made changes -
          Rank Ranked lower
          vivek Vivek Pandey made changes -
          Epic Link JENKINS-35761 [ 171656 ]
          imeredith Ivan Meredith made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          imeredith Ivan Meredith added a comment -

          Might have to implement that rawEncode on the client side. And pray that it doesnt break other things

          imeredith Ivan Meredith made changes -
          Status In Progress [ 3 ] In Review [ 10005 ]
          imeredith Ivan Meredith made changes -
          Status In Review [ 10005 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          tomwtb Tom Wtb made changes -
          Assignee Ivan Meredith [ imeredith ] Tom Waterbley [ tomwtb ]
          tomwtb Tom Wtb made changes -
          Assignee Tom Waterbley [ tomwtb ]
          tomwtb Tom Wtb made changes -
          Assignee Ivan Meredith [ imeredith ]

            People

            • Assignee:
              imeredith Ivan Meredith
              Reporter:
              steven_chen chen po yu
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: