Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48143

No job can be launched after Jenkins upgrade

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Won't Fix
    • Component/s: core
    • Environment:
      Ubuntu 14.04, JDK 8 for system, JDK 7 in /var/lib/jenkins (Jenkins installed via apt-get), the very latest version of Jenkins (2.73.3) is installed.
    • Similar Issues:

      Description

      After a Jenkins upgrade, jobs can no longer last more than a few seconds before ending with :

      {{ ERROR: Aborted Maven execution for InterruptedIOException}}
      {{ java.net.SocketTimeoutException: Accept timed out}}
      {{ at java.net.PlainSocketImpl.socketAccept(Native Method)}}
      {{ at java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:409)}}
      {{ at java.net.ServerSocket.implAccept(ServerSocket.java:545)}}
      {{ at java.net.ServerSocket.accept(ServerSocket.java:513)}}
      {{ at hudson.maven.AbstractMavenProcessFactory$SocketHandler$AcceptorImpl.accept(AbstractMavenProcessFactory.java:213)}}
      {{ at hudson.maven.AbstractMavenProcessFactory.newProcess(AbstractMavenProcessFactory.java:282)}}
      {{ at hudson.maven.ProcessCache.get(ProcessCache.java:236)}}
      {{ at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:804)}}
      {{ at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:496)}}
      {{ at hudson.model.Run.execute(Run.java:1737)}}
      {{ at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)}}
      {{ at hudson.model.ResourceController.execute(ResourceController.java:97)}}
      {{ at hudson.model.Executor.run(Executor.java:421)}}
      {{ Finished: ABORTED}}

      I've compared what is just before the exception in the previous working build, as you can see, some stable maven plugins packaged with Jenkins have been replaced with "alpha" jars which may or may not be the cause of the crash :

      Working previous build :

      [analyse-tweet] $ /var/lib/jenkins/install/jdk1.7.0_75//bin/java -cp /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven31-agent-1.8.1.jar: /var/lib/jenkins/install/apache-maven-3.1.1/boot/plexus-classworlds-2.5.1.jar:/var/lib/jenkins/install/apache-maven-3.1.1/conf/logging jenkins.maven3.agent.Maven31Main /var/lib/jenkins/install/apache-maven-3.1.1/ /var/cache/jenkins/war/WEB-INF/lib/remoting-3.4.1.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven31-interceptor-1.8.1.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven3-interceptor-commons-1.8.1.jar 46935

      Last non working build (with "alpha" plugins) :

      [analyse-tweet] $ /var/lib/jenkins/install/jdk1.7.0_75//bin/java -cp /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven31-agent-1.12-alpha-1.jar: /var/lib/jenkins/install/apache-maven-3.1.1/boot/plexus-classworlds-2.5.1.jar:/var/lib/jenkins/install/apache-maven-3.1.1/conf/logging jenkins.maven3.agent.Maven31Main /var/lib/jenkins/install/apache-maven-3.1.1/ /var/cache/jenkins/war/WEB-INF/lib/remoting-3.10.2.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven31-interceptor-1.12-alpha-1.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven3-interceptor-commons-1.12-alpha-1.jar 51312

      Would there be a simple and safe way to downgrade jenkins or to solve this in any way ?

       

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Maven Projects need to run on a JVM that can run Jenkins. Jenkins needs JRE 8 since 2.60.x.

          See note at https://jenkins-ci.org/changelog-stable/#v2.60.1 and explanation at https://jenkins-ci.org/doc/upgrade-guide/2.60/#java-8-required

          tristan107 Tristan Robet added a comment -

          You are right about this, but it is NOT the cause of this problem.

          Right before it happens, I had also JDK 7 selected and JDK 8 as system jdk, and Jenkins just switched to system jdk (8) emitting a warning in logs. It didn't go in "SocketTimeoutException".

          After a few research, this is a very old random exception occuring from 2009 on Jenkins.

          I've tried this "iptables" solution : https://blogs.forgerock.org/petermajor/2014/09/jenkins-and-the-mysterious-accept-timed-out-error/ and it didn't change anything, but after 2 reboots, the problem is gone.

          oleg_nenashev Oleg Nenashev added a comment -

          > After a few research, this is a very old random exception occuring from 2009 on Jenkins.

          Are there any already reported issues regarding it?

          tristan107 Tristan Robet added a comment -

          Sure, there are, but for other environment, and I didn't see a way to add an environment : https://issues.jenkins-ci.org/browse/JENKINS-44857

          Since it looks like a very low level issue, I thought it was worth adding an issue to signal an other OS.


            People

            • Assignee:
              Unassigned
              Reporter:
              tristan107 Tristan Robet
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: