Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48256

Unable to create ipa for iOS project with Xcode 9, While it is successful for Xcode < 9

    Details

    • Similar Issues:

      Description

      OS - mac os 10.12.6

      Jenkins - 2.81

      Xcode plugin - 2.0.0

      Jenkins running directly

      Note: It is working fine for Xcode < 9, we are able to create ipa.

      Always getting this error.
      Error Domain=IDEProvisioningErrorDomain Code=9

        Attachments

          Issue Links

            Activity

            sharad_goyal sharad goyal created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            How is it related to Jenkins?

            oleg_nenashev Oleg Nenashev added a comment -

            Feel free to reopen the issue if you are ready to provide details for triaging

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Incomplete [ 4 ]
            sharad_goyal sharad goyal added a comment -

            Error Domain=IDEProvisioningErrorDomain Code=9 ""Abc.app" requires a provisioning profile with the Push Notifications and Associated Domains features." UserInfo={NSLocalizedDescription="Abc.app" requires a provisioning profile with the Push Notifications and Associated Domains features., NSLocalizedRecoverySuggestion=Add a profile to the "provisioningProfiles" dictionary in your Export Options property list.}

            Note : From Xcode, We are able to create ipa successfully.

            sharad_goyal sharad goyal added a comment -

            is there any option in jenkins to attach exportOptions.plist file

            oleg_nenashev Oleg Nenashev added a comment -

            Attach to JIRA? Yes, you can attach it here. In the case of jobs use artifact publisher

            sharad_goyal sharad goyal added a comment - - edited

            Sorry, I didn't get you, I am talking about above error. that I am unable to create ipa from jenkins (Xcode 9), while archieve is succeeded. It gives me  Error Domain=IDEProvisioningErrorDomain Code=9

            I need solution for this.

            Thanks

            oleg_nenashev Oleg Nenashev added a comment -

            Well, you reported a Blocker defect to the bugtracker, but have not explained the environnent yet. I have no idea how you invoke Xcode, for example. See the link I have provided above.

            In the current state I cannot help. If you are not ready to provide the diagnosticd info, I suggest asking in Jenkins or Xcode user mailing lists, not in the bugtracker

            sharad_goyal sharad goyal made changes -
            Description Always getting this error.
            Error Domain=IDEProvisioningErrorDomain Code=9
            OS - mac os 10.12

            Jenkins - 2.81

            Xcode plugin - 2.0.0

            Jenkins running directly

            Note: It is working fine for Xcode < 9, we are able to create ipa.

            Always getting this error.
             Error Domain=IDEProvisioningErrorDomain Code=9
            sharad_goyal sharad goyal made changes -
            Description OS - mac os 10.12

            Jenkins - 2.81

            Xcode plugin - 2.0.0

            Jenkins running directly

            Note: It is working fine for Xcode < 9, we are able to create ipa.

            Always getting this error.
             Error Domain=IDEProvisioningErrorDomain Code=9
            OS - mac os 10.12.6

            Jenkins - 2.81

            Xcode plugin - 2.0.0

            Jenkins running directly

            Note: It is working fine for Xcode < 9, we are able to create ipa.

            Always getting this error.
             Error Domain=IDEProvisioningErrorDomain Code=9
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Incomplete [ 4 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            oleg_nenashev Oleg Nenashev made changes -
            Component/s xcode-plugin [ 16124 ]
            Component/s _unsorted [ 19622 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev added a comment -

            OK, now it is reviewable, added to the xcode plugin component

            oleg_nenashev Oleg Nenashev added a comment -

            From what I see, it is a full duplicate of JENKINS-45509. Let's track it there for now

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-45509 [ JENKINS-45509 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                sharad_goyal sharad goyal
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: