Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48362

Regression: 3.0.3 no longer support whitespace in Maven installation path

    Details

    • Similar Issues:

      Description

      Can't find maven provided by jenkins global tools configuration. Jenkins is installed in "c:\program files (x86)\Jenkins" (with whitespaces in path).

      Fails since version 3.0.3.

      Snippet of console output:

      13:34:03.852 [withMaven] use Maven installation 'Maven 3.5.0'
      [Pipeline] {
      [Pipeline] script
      [Pipeline] {
      [Pipeline] bat
      13:34:04.117 [workspace] Running batch script
      13:34:04.377
      13:34:04.378 {workspacePath}>mvn -f ./{pathToPom} clean 
      13:34:04.379 ----- withMaven Wrapper script -----
      13:34:04.379 Der Befehl "C:\Program" ist entweder falsch geschrieben oder
      13:34:04.379 konnte nicht gefunden werden.

        Attachments

          Issue Links

            Activity

            johanneszinn Johannes Zinn created issue -
            johanneszinn Johannes Zinn made changes -
            Field Original Value New Value
            Description Can't find maven provided by jenkins global tools configuration. Jenkins is installed in c:\program files (x86)\Jenkins.

            Fails since version 3.0.3.

             

            Snippet of console output:
            *13:34:03.852* [withMaven] use Maven installation 'Maven 3.5.0'
            [Pipeline] \{
            [Pipeline] script
            [Pipeline] \{
            [Pipeline] bat*13:34:04.117* [workspace] Running batch script*13:34:04.377* *13:34:04.378* \{workspacePath}>mvn -f ./\{pathToPom} clean *13:34:04.379* ----- withMaven Wrapper script -----*13:34:04.379* Der Befehl "C:\Program" ist entweder falsch geschrieben oder*13:34:04.379* konnte nicht gefunden werden.
            provided by jenkins via global configuration
            Can't find maven provided by jenkins global tools configuration. Jenkins is installed in c:\program files (x86)\Jenkins.

            Fails since version 3.0.3.

             

            Snippet of console output:


             *13:34:03.852* [withMaven] use Maven installation 'Maven 3.5.0'
             [Pipeline] \{
             [Pipeline] script
             [Pipeline] \{
             [Pipeline] bat*13:34:04.117* [workspace] Running batch script*13:34:04.377* *13:34:04.378* \{workspacePath}>mvn -f ./\{pathToPom} clean *13:34:04.379* ----- withMaven Wrapper script -----*13:34:04.379* Der Befehl "C:\Program" ist entweder falsch geschrieben oder*13:34:04.379* konnte nicht gefunden werden.
             provided by jenkins via global configuration
            johanneszinn Johannes Zinn made changes -
            Description Can't find maven provided by jenkins global tools configuration. Jenkins is installed in c:\program files (x86)\Jenkins.

            Fails since version 3.0.3.

             

            Snippet of console output:


             *13:34:03.852* [withMaven] use Maven installation 'Maven 3.5.0'
             [Pipeline] \{
             [Pipeline] script
             [Pipeline] \{
             [Pipeline] bat*13:34:04.117* [workspace] Running batch script*13:34:04.377* *13:34:04.378* \{workspacePath}>mvn -f ./\{pathToPom} clean *13:34:04.379* ----- withMaven Wrapper script -----*13:34:04.379* Der Befehl "C:\Program" ist entweder falsch geschrieben oder*13:34:04.379* konnte nicht gefunden werden.
             provided by jenkins via global configuration
            Can't find maven provided by jenkins global tools configuration. Jenkins is installed in "c:\program files (x86)\Jenkins" (with whitespaces in path).

            Fails since version 3.0.3.

            Snippet of console output:
            {code:java}
            13:34:03.852 [withMaven] use Maven installation 'Maven 3.5.0'
            [Pipeline] {
            [Pipeline] script
            [Pipeline] {
            [Pipeline] bat
            13:34:04.117 [workspace] Running batch script
            13:34:04.377
            13:34:04.378 {workspacePath}>mvn -f ./{pathToPom} clean 
            13:34:04.379 ----- withMaven Wrapper script -----
            13:34:04.379 Der Befehl "C:\Program" ist entweder falsch geschrieben oder
            13:34:04.379 konnte nicht gefunden werden.{code}
            cleclerc Cyrille Le Clerc made changes -
            Summary Can't find maven installation within a directory with whitespace Regression: 3.0.3 no longer support whitespace in Maven installation path
            Assignee Alvaro Lobato [ alobato ] Cyrille Le Clerc [ cleclerc ]
            cleclerc Cyrille Le Clerc made changes -
            Link This issue is related to JENKINS-48264 [ JENKINS-48264 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Cyrille Le Clerc
            Path:
            jenkins-plugin/src/main/java/org/jenkinsci/plugins/pipeline/maven/WithMavenStepExecution.java
            http://jenkins-ci.org/commit/pipeline-maven-plugin/4de87539abb92bd817ae37a3edeba0e85dab4477
            Log:
            JENKINS-48362 Support whitespace in Maven installation path

            cleclerc Cyrille Le Clerc made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Cyrille Le Clerc
            Path:
            jenkins-plugin/src/main/java/org/jenkinsci/plugins/pipeline/maven/WithMavenStepExecution.java
            http://jenkins-ci.org/commit/pipeline-maven-plugin/f84632b81004e0a5c4a7455d097f93b65601bc28
            Log:
            Merge pull request #112 from jenkinsci/JENKINS-48362

            JENKINS-48362 Support whitespace in Maven installation path

            Compare: https://github.com/jenkinsci/pipeline-maven-plugin/compare/2da1dbb5bc93...f84632b81004

            cleclerc Cyrille Le Clerc added a comment -

            Fixed in 3.0.5

            cleclerc Cyrille Le Clerc made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            cleclerc Cyrille Le Clerc added a comment -

            Johannes Zinn can you please verify that 3.0.5 fixed your problem?

            johanneszinn Johannes Zinn added a comment -

            3.0.5 fixes my problem. Tank you!!

            johanneszinn Johannes Zinn made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            johanneszinn Johannes Zinn made changes -
            Comment [ 3.0.5 fixes my problem. Tank you!! ]

              People

              • Assignee:
                cleclerc Cyrille Le Clerc
                Reporter:
                johanneszinn Johannes Zinn
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: