Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4840

Clean mode does not work with Forest

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: mercurial-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Currently 'hg fup -C .' is run, which should be OK, but 'hg clean --all' will
      not work on subrepositories. Since there is no 'hg fclean' yet, need to do
      equivalent of

      for r in `hg ftrees`; do hg -R $r clean --all; done

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick created issue -
            jglick Jesse Glick added a comment -

            .

            jglick Jesse Glick made changes -
            Field Original Value New Value
            Link This issue is blocking JENKINS-1143 [ JENKINS-1143 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : jglick
            Path:
            trunk/hudson/plugins/mercurial/src/main/java/hudson/plugins/mercurial/MercurialSCM.java
            trunk/hudson/plugins/mercurial/src/main/webapp/forest.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=23715
            Log:
            [FIXED JENKINS-4840] Make Clean Build work even with Forest enabled.

            scm_issue_link SCM/JIRA link daemon made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jglick Jesse Glick added a comment -
                • Issue 4883 has been marked as a duplicate of this issue. ***
            jglick Jesse Glick made changes -
            Link This issue is duplicated by JENKINS-4883 [ JENKINS-4883 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 134913 ] JNJira + In-Review [ 203140 ]

              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                jglick Jesse Glick
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: