Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48468

EC2 plugin randomly switches instance type from windows to unix

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: ec2-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.89.1
      Amazon EC2 plugin 1.37
    • Similar Issues:

      Description

      We are observing an issue where a configured aws ec2 cloud instance configuration randomly switches its type from Windows to Unix. The rest of configuration is unaffected, but this leads to agent being started afterwards to get stuck looking for ssh which, obviously, will never happen.

      There is nothing in the logs that suggests what might be the cause, but this seems to correlate with ether jenkins version upgrade or global configuration change events. Popping into global configuration, changing instance type back to windows and re-adding password (and deleting the agent(s) stuck at the time when this is noticed) gets everything back to normal into the horrors of winRM land.

      This has been ongoing with the past 3-4 LTS versions and with at least last 2 ec2 plugin versions.

      Magic like somebody rolling back local configurations on disk or similar have been excluded.

      (I know this is not particularly useful issue report, but raising for the record and just in case if somebody else finds the title with the same issue)

        Attachments

          Issue Links

            Activity

            oltzu Olli Sivonen added a comment -

            Seems to be a duplicate of JENKINS-47985.

            homolupus Karlis Zigurs added a comment -

            Thanks, indeed a duplicate.


              People

              • Assignee:
                francisu Francis Upton
                Reporter:
                homolupus Karlis Zigurs
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: