Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48674

Automated installation of docker fail for recent version of docker (> 17.05.0-ce)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: docker-commons-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.32.1
      Docker Commons Plugin 1.10
    • Similar Issues:

      Description

      Using the pipeline integration, the build fails to download/install latest docker release.

      When using the same url from my laptop, it returns a jpg with a 404 message.

      java.io.IOException: Failed to install https://get.docker.com/builds/Linux/x86_64/docker-17.09.0-ce.tgz
      to /var/lib/jenkins/tools/org.jenkinsci.plugins.docker.commons.tools.DockerTool/17.09.1-ce
      at hudson.FilePath.installIfNecessaryFrom(FilePath.java:854)
      at hudson.FilePath.installIfNecessaryFrom(FilePath.java:762)
      at org.jenkinsci.plugins.docker.commons.tools.DockerToolInstaller.performInstallation(DockerToolInstaller.java:129)
      at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:72)
      at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:109)
      at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:206)
      at org.jenkinsci.plugins.docker.commons.tools.DockerTool.forNode(DockerTool.java:107)
      at org.jenkinsci.plugins.docker.commons.tools.DockerTool.forNode(DockerTool.java:53)
      at org.jenkinsci.plugins.workflow.steps.ToolStep$Execution.run(ToolStep.java:146)
      at org.jenkinsci.plugins.workflow.steps.ToolStep$Execution.run(ToolStep.java:127)
      at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1$1.call(SynchronousNonBlockingStepExecution.java:49)
      at hudson.security.ACL.impersonate(ACL.java:221)
      at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1.run(SynchronousNonBlockingStepExecution.java:46)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: https://get.docker.com/builds/Linux/x86_64/docker-17.09.0-ce.tgz
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
      at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1890)
      at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1885)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1884)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1457)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at org.jvnet.robust_http_client.RetryableHttpStream.getStream(RetryableHttpStream.java:98)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:91)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:74)
      at hudson.ProxyConfiguration.getInputStream(ProxyConfiguration.java:264)
      at hudson.FilePath.installIfNecessaryFrom(FilePath.java:840)
      ... 17 more
      Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: https://get.docker.com/builds/Linux/x86_64/docker-17.09.0-ce.tgz
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1840)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)
      at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:2943)
      at java.net.URLConnection.getHeaderFieldLong(URLConnection.java:629)
      at java.net.URLConnection.getContentLengthLong(URLConnection.java:501)
      at java.net.URLConnection.getContentLength(URLConnection.java:485)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getContentLength(HttpsURLConnectionImpl.java:398)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:90)
      ... 20 more
      Finished: FAILURE

        Attachments

          Activity

          d_n_a Denis Antonioli added a comment - - edited

          The docker images seems to have moved to <https://download.docker.com/linux/static/stable/x86_64/ docker-17.09.0-ce.tgz>

          I can't find a reference for the change from get.docker.com to download.docker.com

          jglick Jesse Glick added a comment -

          Fixing up some minor issues in PR 64.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Denis N. Antonioli
          Path:
          src/main/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstaller.java
          src/test/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstallerTest.java
          http://jenkins-ci.org/commit/docker-commons-plugin/00a18c29c8d9e005a969432910acb7ef4eef7c0a
          Log:
          JENKINS-48674: downloads image for newer version from download.docker.com

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Denis N. Antonioli
          Path:
          src/main/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstaller.java
          src/test/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstallerTest.java
          http://jenkins-ci.org/commit/docker-commons-plugin/a433acfb37fcdbef4efd739d721eccc971a0f593
          Log:
          JENKINS-48674: (1) use the edge instead of the stable channel, it contains every available binaries
          (2) refactor the string manipulations: findArch concerned only with architecture, getDockerImageUrl with the url path

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          src/main/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstaller.java
          src/test/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstallerTest.java
          http://jenkins-ci.org/commit/docker-commons-plugin/ca19d3c2eef13be7925c3b87871a0a3cf50b6978
          Log:
          Merge branch 'JENKINS-48674' of https://github.com/denisa/docker-commons-plugin into installer-JENKINS-48674

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          src/main/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstaller.java
          src/main/resources/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstaller/help-version.html
          src/test/java/org/jenkinsci/plugins/docker/commons/tools/DockerToolInstallerTest.java
          http://jenkins-ci.org/commit/docker-commons-plugin/c7dfbcae48f0edcf3e25646f33e5fa619b0c070b
          Log:
          Merge pull request #64 from jglick/installer-JENKINS-48674

          JENKINS-48674 Fix installer

          Compare: https://github.com/jenkinsci/docker-commons-plugin/compare/b34c6f3ca421...c7dfbcae48f0


            People

            • Assignee:
              d_n_a Denis Antonioli
              Reporter:
              d_n_a Denis Antonioli
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: