Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49041

clobber is always true

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: p4-plugin
    • Labels:
      None
    • Environment:
      P4 Plugin 1.8.4
      Jenkins ver. 2.87
    • Similar Issues:

      Description

      Hello

      P4 plugin always creates workspaces with 'clobber: true' even if 'clobber: false' was specified.

      Example:

      node {
       checkout perforce(
       credential: 'e0cd5f60-0ddd-4289-b0f3-xxxxxxxxx', 
       populate: autoClean(delete: true, modtime: false, parallel: [enable: false, minbytes: '1024', minfiles: '1', threads: '4'], 
       pin: '', quiet: true, replace: true, tidy: false), 
       workspace: manualSpec(charset: 'none', name: 'xxx', pinHost: false, 
       spec: clientSpec(allwrite: false, backup: false, clobber: false, compress: false, line: 'LOCAL', locked: false, modtime: false, rmdir: false, serverID: '', streamName: '', type: 'WRITABLE', 
       view: "//depot/stream/Jenkinsfile //xxx/Jenkinsfile")))
      }
      

       

       

      > p4 workspace -o xxx
      
      Client: xxx
      Owner: xxx
      Root: /home/xxx/workspace/xxx
      Options: noallwrite clobber nocompress unlocked nomodtime normdir
      SubmitOptions: submitunchanged
      LineEnd: local
      View:
      //depot/stream/Jenkinsfile //xxx/Jenkinsfile
      

      Please fix.

      Thank you

        Attachments

          Activity

          p4paul Paul Allen added a comment -

          Intended by design.

          lystor Mykola Ulianytskyi added a comment -

          If it intended by design - it is better to remove confusing parameter clobber...

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Paul Allen
          Path:
          src/main/java/org/jenkinsci/plugins/p4/client/ClientHelper.java
          src/main/java/org/jenkinsci/plugins/p4/workspace/StreamDescImpl.java
          src/main/java/org/jenkinsci/plugins/p4/workspace/StreamWorkspaceImpl.java
          src/main/java/org/jenkinsci/plugins/p4/workspace/WorkspaceSpec.java
          src/main/resources/org/jenkinsci/plugins/p4/workspace/WorkspaceSpec/config.jelly
          http://jenkins-ci.org/commit/p4-plugin/a7449fd169edf0ba403eca1f3f70c9b9904b2929
          Log:
          Remove forced clobber and set default clobber option to true.

          JENKINS-49041

          p4paul Paul Allen added a comment -

          Released in 1.8.5

          lystor Mykola Ulianytskyi added a comment -

          Thank you


            People

            • Assignee:
              p4paul Paul Allen
              Reporter:
              lystor Mykola Ulianytskyi
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: