Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4919

authorization failed: Could not authenticate to server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: googlecode-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      when I tried to also use the Hudson Maven Release Plug-in Plug-in with it, it
      always failed to authenticate...

      [INFO] Checking in modified POMs...
      [INFO] Executing: cmd.exe /X /C "svn --username cheng.lee --password *****
      --non-interactive commit --file
      C:\DOCUME~1\SG0911~1\LOCALS~1\Temp\maven-scm-418604701.commit --targets
      C:\DOCUME~1\SG0911~1\LOCALS~1\Temp\maven-scm-4679798912759164772-targets"
      [INFO] Working directory: C:\Documents and
      Settings\sg0911238\.hudson\jobs\lucene-log4j\workspace\.
      [HUDSON] Archiving C:\Documents and
      Settings\sg0911238\.hudson\jobs\lucene-log4j\workspace\.\pom.xml to C:\Documents
      and
      Settings\sg0911238\.hudson\jobs\lucene-log4j\modules\com.googlecode.lucene-log4j$lucene-log4j\builds\2009-11-20_21-08-12\archive\com.googlecode.lucene-log4j\lucene-log4j\1.0.0-SNAPSHOT\pom.xml
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Unable to commit files
      Provider message:
      The svn command failed.
      Command output:
      svn: Commit failed (details follow):
      svn: MKACTIVITY of '/svn/!svn/act/63efbb1b-df19-b649-8847-d44cd30f4d79':
      authorization failed: Could not authenticate to server: rejected Basic challenge
      (http://lucene-log4j.googlecode.com)

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.BuildFailureException: Unable to commit files
      Provider message:
      The svn command failed.
      Command output:
      svn: Commit failed (details follow):
      svn: MKACTIVITY of '/svn/!svn/act/63efbb1b-df19-b649-8847-d44cd30f4d79':
      authorization failed: Could not authenticate to server: rejected Basic challenge
      (http://lucene-log4j.googlecode.com)

      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:699)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:553)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:523)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:268)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
      at
      org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:165)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:159)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:688)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:634)
      at hudson.remoting.UserRequest.perform(UserRequest.java:104)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:244)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: org.apache.maven.plugin.MojoFailureException: Unable to commit files
      Provider message:
      The svn command failed.
      Command output:
      svn: Commit failed (details follow):
      svn: MKACTIVITY of '/svn/!svn/act/63efbb1b-df19-b649-8847-d44cd30f4d79':
      authorization failed: Could not authenticate to server: rejected Basic challenge
      (http://lucene-log4j.googlecode.com)

      at
      org.apache.maven.plugins.release.PrepareReleaseMojo.execute(PrepareReleaseMojo.java:169)
      at
      org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:483)
      at
      hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:182)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)
      ... 28 more

      This was because it was using http instead of https to do the checkout. I had
      set "Google Code (Automatic Configuration)" on Source Code Management of the
      hudson project. Instead of relying on Hudson GoogleCode plugin, I used
      Malachi's workaround posted at
      http://malsserver.blogspot.com/2009/04/hudson-maven-release-plug-in-plug-in.html
      which use Subversion as Source Code Management and entered the https url for my
      project.

      Would it be possible for you to fix this?

      Many thanks!

        Attachments

          Issue Links

            Activity

            redsolo redsolo added a comment -

            I guess there really is no reason to use the http protocol instead of https? If not, I can roll this out in a few days.

            chenglee chenglee added a comment -

            I think it's not a matter of using http instead of https but rather using <Connection> instead of <developerConnection> in the pom.xml

            Many thanks!

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : redsolo
            Path:
            trunk/hudson/plugins/googlecode/src/main/java/hudson/plugins/googlecode/GoogleCodeProjectProperty.java
            trunk/hudson/plugins/googlecode/src/test/java/hudson/plugins/googlecode/GoogleCodeProjectPropertyTest.java
            trunk/hudson/plugins/googlecode/src/test/java/hudson/plugins/googlecode/scm/GoogleCodeSCMExIntegrationTest.java
            trunk/hudson/plugins/googlecode/src/test/java/hudson/plugins/googlecode/scm/GoogleCodeSCMExTest.java
            trunk/hudson/plugins/googlecode/src/test/java/hudson/plugins/googlecode/scm/GoogleCodeSCMUpgraderTest.java
            http://jenkins-ci.org/commit/27089
            Log:
            [FIXED JENKINS-4919] Changed protocol for the subversion url from http:// to https://

            redsolo redsolo added a comment -

            Could you verify that this issue has been fixed before I release a new version? If you would like to, you can get a snapshot at http://hudson.ramfelt.se/job/Hudson%20plugin%20Google%20Code/


              People

              • Assignee:
                redsolo redsolo
                Reporter:
                chenglee chenglee
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: