Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4938

Alternate settings file cannot be located

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Linux
    • Similar Issues:
      Show 5 results

      Description

      When alternate settings.xml files are located in the workspace, they should be
      referable via the 'Alternate settings file' options. However when we enter the
      path as: "sccm-conf/sccm-conf/settings-snapshot.xml" we get a message that this
      file cannot be found.
      When we do a run we get a message:
      "sccm/var/db/hudson/jobs/SCCM-demo-applicatie/workspace/trunk/sccm-conf/sccm-conf/settings-snapshot.xml"
      which is indeed the wrong path. The 'trunk' part should not be there.
      This seems to be inherited from the SVN URL that we use (we checkout 2 projects
      and the first one ends in 'trunk').

        Attachments

          Issue Links

            Activity

            pleursoft pleursoft created issue -
            pleursoft pleursoft added a comment -

            Trying to alter the location of the settings.xml by adding ../ in front results
            in
            "/sccm/var/db/hudson/jobs/SCCM-demo-applicatie/workspace/../sccm-conf/sccm-conf/settings-snapshot.xml"
            (basically, Hudson is also removing the 'trunk' part and the '..' of the path is
            added as well).
            Add "../workspace/" adds 'trunk' again so this seems like a cycle we cannot break.

            pleursoft pleursoft added a comment -

            Using '-s $

            {WORKSPACE}

            /sccm-conf/sccm-conf/settings-snapshot.xml' as a Maven
            option works.

            pleursoft pleursoft made changes -
            Field Original Value New Value
            Link This issue is blocking JENKINS-4939 [ JENKINS-4939 ]
            pleursoft pleursoft added a comment -

            Duplicate of #4693 (how can the submitted correct this??)

            mdonohue mdonohue made changes -
            Link This issue duplicates JENKINS-4693 [ JENKINS-4693 ]
            mdonohue mdonohue made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Duplicate [ 3 ]
            mdonohue mdonohue made changes -
            Link This issue is blocking JENKINS-4939 [ JENKINS-4939 ]
            ircbot IRCbot Run by Kohsuke made changes -
            Component/s maven-plugin [ 16033 ]
            Component/s maven2 [ 15487 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                pleursoft pleursoft
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: