Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49490

Failed to run AVD creation on MAC

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Started by user
      sumit kathuria
      Building in workspace /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins
      [android] Failed to create file or directory: /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins/.android
      $ /Users/sumit.kathuria/Library/Android/sdk/tools/bin/avdmanager list target
      [android] The configured Android platform needs to be installed: android-19
      $ /Users/sumit.kathuria/Library/Android/sdk/tools/bin/avdmanager list target
      $ /Users/sumit.kathuria/Library/Android/sdk/tools/bin/avdmanager list target
      [android] Installing the 'android-19,sys-img-x86_64-google_apis-19' SDK component(s)...
      $ /Users/sumit.kathuria/Library/Android/sdk/tools/bin/sdkmanager --include_obsolete platforms;android-19 system-images;android-19;google_apis;x86_64
      Loading package information...
      Loading local repository...
      [ ] 3% Loading local repository...
      [ ] 3% Fetch remote repository...
      [ ] 3% Fetch remote repository...
      [= ] 3% Fetch remote repository...
      [= ] 4% Fetch remote repository...

      Warning: File /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins/.android/repositories.cfg could not be loaded.
      [= ] 4% Fetch remote repository...
      [= ] 4% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [= ] 5% Fetch remote repository...
      [== ] 5% Fetch remote repository...
      [== ] 5% Fetch remote repository...
      [== ] 5% Fetch remote repository...
      [== ] 5% Fetch remote repository...
      [== ] 5% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Fetch remote repository...
      [== ] 6% Computing updates...
      [=== ] 8% Computing updates...
      [=== ] 8% Computing updates...
      [=== ] 10% Computing updates...

      Warning: Failed to find package system-images;android-19;google_apis;x86_64
      [=== ] 10% Computing updates...
      [android] Using Android SDK: /Users/sumit.kathuria/Library/Android/sdk
      [android] Creating Android AVD: /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins/.android/avd/hudson_en-US_160_HVGA_android-19_google_apis-x86_64.avd
      [android] /Users/sumit.kathuria/Library/Android/sdk/tools/bin/avdmanager create avd -f -c 64M -n hudson_en-US_160_HVGA_android-19_google_apis-x86_64 -k system-images;android-19;google_apis;x86_64 --tag google_apis
      Loading local repository...
      [========= ] 25% Loading local repository...
      [========= ] 25% Fetch remote repository...
      [========= ] 25% Fetch remote repository...
      [========= ] 25% Fetch remote repository...
      [=======================================] 100% Fetch remote repository...
      Error: Package path is not valid. Valid system image paths are:
      system-images;android-24;google_apis;x86
      null

      [android] Failed to run AVD creation command
      [android] Could not create Android emulator: Failed to run AVD creation command
      Finished: NOT_BUILT

        Attachments

          Activity

          Hide
          sumitkathuria theexplorer added a comment -

          Christopher Orr Any suggestions ?

          Show
          sumitkathuria theexplorer added a comment - Christopher Orr Any suggestions ?
          Hide
          orrc Christopher Orr added a comment -

          The log says:

          > Warning: Failed to find package system-images;android-19;google_apis;x86_64

          Indeed, running sdkmanager --list | grep android-19 shows that there is no x86_64 image for Android 19 with Google APIs.  You would need to use x86.

          Show
          orrc Christopher Orr added a comment - The log says: > Warning: Failed to find package system-images;android-19;google_apis;x86_64 Indeed, running sdkmanager --list | grep android-19 shows that there is no x86_64 image for Android 19 with Google APIs.  You would need to use x86 .
          Hide
          sumitkathuria theexplorer added a comment -

          Thanks a lot Christopher Orr , now i am getting this error : please check !
          [android] Starting Android emulator
          $ /Users/sumit.kathuria/Library/Android/sdk/emulator/emulator -skin 320x480 -ports 5760,5761 -report-console tcp:5840,max=60 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_160_HVGA_android-24_google_apis-x86 -no-window
          _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.
          emulator: WARNING: Requested adb port (5761) is outside the recommended range [5555,5586]. ADB may not function properly for the emulator. See -help-port for details.
          [android] Emulator reported that the console is available on port 5,760
          [android] Waiting for emulator to finish booting...
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 wait-for-device shell getprop init.svc.bootanim
          [android] Emulator reported that the startup process is 'stopped'
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell logcat -v time
          [android] Attempting to unlock emulator screen
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell wm dismiss-keyguard
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell input keyevent 4
          [android] Emulator is ready for use (took 13 seconds)
          [android] Stopping Android emulator
          emulator: Saving state on exit with session uptime 7540 ms
          [android] Archiving emulator log
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb kill-server
          Finished: SUCCESS

          Show
          sumitkathuria theexplorer added a comment - Thanks a lot Christopher Orr , now i am getting this error : please check ! [android] Starting Android emulator $ /Users/sumit.kathuria/Library/Android/sdk/emulator/emulator -skin 320x480 -ports 5760,5761 -report-console tcp:5840,max=60 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_160_HVGA_android-24_google_apis-x86 -no-window _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL. emulator: WARNING: Requested adb port (5761) is outside the recommended range [5555,5586] . ADB may not function properly for the emulator. See -help-port for details. [android] Emulator reported that the console is available on port 5,760 [android] Waiting for emulator to finish booting... $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 wait-for-device shell getprop init.svc.bootanim [android] Emulator reported that the startup process is 'stopped' $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell logcat -v time [android] Attempting to unlock emulator screen $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell wm dismiss-keyguard $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb -s emulator-5760 shell input keyevent 4 [android] Emulator is ready for use (took 13 seconds) [android] Stopping Android emulator emulator: Saving state on exit with session uptime 7540 ms [android] Archiving emulator log $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb kill-server Finished: SUCCESS
          Hide
          orrc Christopher Orr added a comment -

          I don't see any problems here: the emulator started, you apparently didn't have any further build steps, the emulator was shut down, and the build completed successfully.

          Show
          orrc Christopher Orr added a comment - I don't see any problems here: the emulator started, you apparently didn't have any further build steps, the emulator was shut down, and the build completed successfully.
          Hide
          sumitkathuria theexplorer added a comment -

          Thanks for the quick response Christopher Orr

          Getting error in case of "show emulator window"
          Warning: File /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins/.android/repositories.cfg could not be loaded.
          [android] Using Android SDK: /Users/sumit.kathuria/Library/Android/sdk
          $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb start-server

          • daemon not running; starting now at tcp:5844
          • daemon started successfully
            $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb start-server
            [android] Starting Android emulator
            $ /Users/sumit.kathuria/Library/Android/sdk/emulator/emulator -skin 320x480 -ports 5742,5743 -report-console tcp:5823,max=60 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_160_HVGA_android-24_google_apis-x86
            _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.
            _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.
            PasteBoard: Error creating pasteboard: com.apple.pasteboard.clipboard [-4960]
            PasteBoard: Error creating pasteboard: com.apple.pasteboard.find [-4960]
            [android] Emulator did not appear to start; giving up
            [android] Stopping Android emulator
            $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb kill-server
            Finished: NOT_BUILT
          Show
          sumitkathuria theexplorer added a comment - Thanks for the quick response Christopher Orr Getting error in case of "show emulator window" Warning: File /Users/Shared/Jenkins/Home/workspace/emulator_of_jenkins/.android/repositories.cfg could not be loaded. [android] Using Android SDK: /Users/sumit.kathuria/Library/Android/sdk $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb start-server daemon not running; starting now at tcp:5844 daemon started successfully $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb start-server [android] Starting Android emulator $ /Users/sumit.kathuria/Library/Android/sdk/emulator/emulator -skin 320x480 -ports 5742,5743 -report-console tcp:5823,max=60 -prop persist.sys.language=en -prop persist.sys.country=US -avd hudson_en-US_160_HVGA_android-24_google_apis-x86 _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL. _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL. PasteBoard: Error creating pasteboard: com.apple.pasteboard.clipboard [-4960] PasteBoard: Error creating pasteboard: com.apple.pasteboard.find [-4960] [android] Emulator did not appear to start; giving up [android] Stopping Android emulator $ /Users/sumit.kathuria/Library/Android/sdk/platform-tools/adb kill-server Finished: NOT_BUILT

            People

            • Assignee:
              orrc Christopher Orr
              Reporter:
              sumitkathuria theexplorer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: