Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49582

uninformative "Failure" error message when publish-over-ssh fails due to disk space on destination

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      jenkins 2.98
      publish-over-ssh 1.17
    • Similar Issues:

      Description

      the error message reported ("Failure") when a publish-over-ssh fails due to lack of disk space on destination really doesn't say anything useful:

      Feb 14, 2018 4:52:48 AM jenkins.plugins.publish_over.BPInstanceConfig perform
      WARNING: An exception was caught when invoking perform
      jenkins.plugins.publish_over.BapPublisherException: Exception when publishing, exception message [Failure]
              at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:69)
              at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:38)
              at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2813)
              at hudson.remoting.UserRequest.perform(UserRequest.java:210)
              at hudson.remoting.UserRequest.perform(UserRequest.java:53)
              at hudson.remoting.Request$2.run(Request.java:358)
              at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
              at java.util.concurrent.FutureTask.run(FutureTask.java:266)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
              at java.lang.Thread.run(Thread.java:745)
              Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to <redacted-destination>
                      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1696)
                      at hudson.remoting.UserResponse.retrieve(UserRequest.java:313)
                      at hudson.remoting.Channel.call(Channel.java:909)
                      at hudson.FilePath.act(FilePath.java:998)
                      at hudson.FilePath.act(FilePath.java:987)
                      at jenkins.plugins.publish_over.BPInstanceConfig.perform(BPInstanceConfig.java:141)
                      at jenkins.plugins.publish_over.BPPlugin.perform(BPPlugin.java:126)
                      at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81)
                      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
                      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
                      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:690)
                      at hudson.model.Build$BuildExecution.post2(Build.java:186)
                      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:635)
                      at hudson.model.Run.execute(Run.java:1752)
                      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
                      at hudson.model.ResourceController.execute(ResourceController.java:97)
                      at hudson.model.Executor.run(Executor.java:429)
      Caused by: 4: Failure
              at com.jcraft.jsch.ChannelSftp.throwStatusError(ChannelSftp.java:2873)
              at com.jcraft.jsch.ChannelSftp.checkStatus(ChannelSftp.java:2486)
              at com.jcraft.jsch.ChannelSftp._put(ChannelSftp.java:651)
              at com.jcraft.jsch.ChannelSftp.put(ChannelSftp.java:540)
              at com.jcraft.jsch.ChannelSftp.put(ChannelSftp.java:492)
              at jenkins.plugins.publish_over_ssh.BapSshClient.transferFile(BapSshClient.java:134)
              at jenkins.plugins.publish_over_ssh.BapSshClient.transferFile(BapSshClient.java:45)
              at jenkins.plugins.publish_over.BPTransfer.transferFile(BPTransfer.java:171)
              at jenkins.plugins.publish_over.BPTransfer.transfer(BPTransfer.java:155)
              at jenkins.plugins.publish_over.BPTransfer.transfer(BPTransfer.java:142)
              at jenkins.plugins.publish_over.BapPublisher$Performer.transfer(BapPublisher.java:276)
              at jenkins.plugins.publish_over.BapPublisher$Performer.perform(BapPublisher.java:232)
              at jenkins.plugins.publish_over.BapPublisher$Performer.access$000(BapPublisher.java:205)
              at jenkins.plugins.publish_over.BapPublisher.perform(BapPublisher.java:158)
              at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:65)
              ... 10 more
      

      it would be reeeeeeeely helpful if the cause of the failure could be reported in some more detail; it would really save lots of wild-anatidae-chasing

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Alex Earl The default assignee still points to bap. Maybe makes sense to remove assignee or change it to you

          slide_o_mix Alex Earl added a comment -

          There really isn't anything in the call stack that would allow me to tell the user that the disk space is low.

          dchsueh Daniel Hsueh added a comment -

          I took a brief look at the jenkins code and see that any error would be reported by https://github.com/rtyley/jsch/blob/master/src/com/jcraft/jsch/ChannelSftp.java

           

          (I'll investigate a bit more shortly and maybe file a suggestion with jsch)

           


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              dchsueh Daniel Hsueh
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: