Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49625

Config pages of Maven jobs do no load

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core, maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.108
    • Similar Issues:

      Description

      Hi,

      we did an upgrade from 2.103 to 2.108 today. After the update we noticed that some xUnit related jobs were failing.

      So we went ahead and tried to open the job configurations page and failed. We were and are unable to open job configuration pages. This seems to "only" affect Maven jobs for us, but we see no error logs or anything else that would give us a hint what the root cause of this error is.

      I already tried creating a fresh job, but this doesn't work as well.

       

      Any help is highly appreciated as this is basically blocking any work with Jenkins at the moment. It would also help if you could clarify if the xUnit step problem might be related or not.

       

      Cheers,

      Christoph

        Attachments

          Issue Links

            Activity

            orthmac Christian Orthmann added a comment -

            I discovered the same problem with version 2.106. When updating to 2.107, the problem was solved but when going to 2.108 it was back again.

            rgoers Ralph Goers added a comment -

            Please take a look at the workaround we found for JENKINS-49630.

            christophdreis Christoph Dreis added a comment -

            I appreciate the workaround, Ralph Goers. Yet, this doesn't seem to confirm that the root cause is actually in the XML file parsing. It only confirms that one could go back to 2.104.

            ferratello Mauro Ferratello added a comment -

            I don't know if it's related, but, as in JENKINS-49630 may be caused by an outdated plugin that try to parse some xml files, like the Violations plugin and so on.

            christophdreis Christoph Dreis added a comment -

            Indeed related, but can be closed as the root cause provided in JENKINS-49630 is in fact the Violations plugin.


              People

              • Assignee:
                Unassigned
                Reporter:
                christophdreis Christoph Dreis
              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: