Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49673

Auto-installation use wrong PATH separator

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: nodejs-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.46.3, NodeJS 1.2.4, Windows 7 x64 slave
    • Similar Issues:

      Description

      When using auto-installation from zip file the PATH is wrongly updated using colon ':' instead semicolon ';' (i.e. '...
      tools\jenkins.plugins.nodejs.tools.NodeJSInstallation\LTS\node-v8.9.4-win-x64:C:\Program Files\...'
      This cause node and npm executable not found by build task.

        Attachments

          Issue Links

            Activity

            nfalco Nikolas Falco added a comment -

            This is not a bug of nodejs, the plugin use the API to concatenate the PATHs. The issue happens if you have a Master on linux and a slave on windows. Because the concatenate is calculate on master node. This bug was fixed in jenkins core. Update your Jenkins >= 2.60.3.


              People

              • Assignee:
                nfalco Nikolas Falco
                Reporter:
                jmusek Josef Musek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: