Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49778

If one stage in the pipeline fails, all the states are marked/color with the same status color

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
      None
    • Environment:
      Jenkins 2.108, Blue Ocean Plugin 1.42
    • Similar Issues:

      Description

      I have a simple, linear pipeline with 3 steps: build/integration tests/functional tests.

      Some functional tests fail, so that stage is marked as unstable. The whole pipeline is then marked as unstable, which is fine.

      But in the UI the nodes for the build and the integration tests are also marked as unstable (yellow circle with ! on it), which is not fine, they passed successfully.

      This is misleading users, in my opinion.

        Attachments

          Issue Links

            Activity

            brianjmurrell Brian J Murrell added a comment -

            I upped the Priority here to Critical as this is almost a show-stopper for being able to deploy useful Pipeline jobs with many stages.

            It's cumbersome on the user to have to hunt through the results of a pipeline job to figure out which stage was actually unstable and which ones were not.

            I have also changed the Component/s to pipeline since this issue has ramifications outside of Blue Ocean and is not directly related to Blue Ocean in my estimation.  Blue Ocean is just the visual representation of the underlying issue with Pipeline jobs setting all stages to unstable when only a subset are actually unstable.  For example, when one uses the Pipeline Githubnotify Step Plugin to set commit statuses for each stage on a Github PR, they all get set to FAILURE even though only a subset actually failed.

            That all said, this is probably a duplicate of JENKINS-39203.


              People

              • Assignee:
                Unassigned
                Reporter:
                ccaraivan Costin Caraivan
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: