Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49962

P4 Plugin: The P4 client uses jenkins_home instead of workspace as root.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: p4-plugin
    • Labels:
    • Environment:
      Jenkins 2.46.1, P4 Plug in 1.4.14
    • Similar Issues:

      Description

      This is very strange and I hadn't been able to nail it yet since it happened inconsistently where sometimes the p4 plugin would essentially use the ${JENKINS_HOME} as the root and sometimes use the ${WORKSPACE} as the root (as far as I can tell)...  The ${WORKSPACE} is what we wanted it to use.

      So, even within the same "job"; this will happen. 

      Our Workspace Name within the Perforce Software is specified to be jenkins-pdkmfg-${JOBNAME}.  

      If I looked at the console logs, or that I check the p4 client:

      p4 client -o jenkins-pdkmfg-my_job_name

      I would see the root defined as

      /proj/gde_pdk_scratch/jenkins/prod/p4/worksapce/my_job_name

      which is where our workspace is defined and which is what we wanted, but sometimes also as:

      /home/pdkmfg/tools/prod/jenkins_home

      which caused a lot of problems...  Sometimes it would just fail; but on some occasion, our jenkins_home got wiped (I think that is because some of our jobs we set the Auto Clean or Force Sync.)

      What could cause P4 plugin to use JENKINS_HOME as root instead of WORKSPACE or if there is a way for me to make sure that it is using WORKSPACE.

      Thanks and Regards...

       

        Attachments

          Activity

          ravennous Raven Alef added a comment -

          I've seen this on Jenkins ver. 2.109 P4 Plugin 1.8.6 please look into this.

          chungley2000 Chung Ley added a comment -

          Just wanted to give everyone who is interested an update.  When we first encountered this problem, we were running P4 Plug in version 1.4.14, and then I swear that I had upgrade to P4 Plug in from 1.4.14 to 1.8.6 and still had this issue.  I then reached out to P4 Support and got a "debugging" version of 1.8.6 installed about 3 weeks ago so that I can send them the log file with more messages when it happened.  However, I had not experienced the problem then....  Sigh...

          p4karl Karl Wirth added a comment -

          I'm unable to reproduce this so for now will close this issue. If it's seen again please feel free to reopen it and I will work directly with you.

          p4karl Karl Wirth added a comment -

          Unable to reproduce this. Happy to work directly on this if it occurs again.


            People

            • Assignee:
              Unassigned
              Reporter:
              chungley2000 Chung Ley
            • Votes:
              6 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: