Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-50301

[JDK9] Java WebStart Unsupported past Java 8

    Details

    • Similar Issues:

      Description

      Oracle has stated that Java WebStart will not be supported past Java SE 8. This may affect launching Agents manually via JNLP.

      http://www.oracle.com/technetwork/java/eol-135779.html

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            My proposal is to detach it from the Jenkins Core as a part of JENKINS-51820

            Show
            oleg_nenashev Oleg Nenashev added a comment - My proposal is to detach it from the Jenkins Core as a part of JENKINS-51820
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            I tested it on Java 11.
            The UI still works, but obviosly it does nothing with modern Java versions.
            The agents are still able to connect using CLI.

            Show
            oleg_nenashev Oleg Nenashev added a comment - I tested it on Java 11. The UI still works, but obviosly it does nothing with modern Java versions. The agents are still able to connect using CLI.
            Hide
            batmat Baptiste Mathus added a comment -

            AFAIK this has been fixed/clarified in Jenkins 2.153+ thanks to Mark Waite in https://github.com/jenkinsci/jenkins/pull/3766.

            https://jenkins.io/redirect/java11-java-web-start :

            > In March 2018, Oracle announced it will not include Java Web Start in Java SE 11 (18.9 LTS) and later. Developers will need to transition to other deployment technologies[3].

             

            Given the technology is not anyway available "upstream", the Jenkins Project can obviously not provide support anymore to this.

             

            Thanks!

            Show
            batmat Baptiste Mathus added a comment - AFAIK this has been fixed/clarified in Jenkins 2.153+ thanks to Mark Waite in https://github.com/jenkinsci/jenkins/pull/3766 . https://jenkins.io/redirect/java11-java-web-start : > In March 2018, Oracle announced it will not include Java Web Start in Java SE 11 (18.9 LTS) and later. Developers will need to transition to other deployment technologies [3] .   Given the technology is not anyway available "upstream", the Jenkins Project can obviously not provide support anymore to this.   Thanks!

              People

              • Assignee:
                Unassigned
                Reporter:
                krachynski Ken Rachynski
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: