Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-50497

Manually triggered Promoted builds is not visible to users who are not Admins unless they are on the `Approvers` list

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: promoted-builds-plugin
    • Labels:
      None
    • Environment:
      Jenkins Core 2.107.x
      Promoted builds 3.0 + 3.1
    • Similar Issues:

      Description

      Issue:

      When a user has full job permissions(build, create, promote....) on Jenkins but not Overall Admin access, they can not manually promote a job using the button.

       

      Steps to reproduce:

      1. Spawn up a new Jenkins instance with 2 users: Admin(full admin permissions), Developer(full job permissions and overall read) and the promoted builds plugin installed
      2. Create a new job with a manual promotion process having no "Approvers" list
      3. Build the Job
      4. Observe that Admin can promote the build but Developer does not have access to the button to promote

      Workaround:

      Adding the Developer user to the list of approvers makes the button show up

       

      Expected Behavior:

      I would expect the Developer user to also have access to the promotion process since they have job promote permission

       

      Let me know if I can clarify anything

        Attachments

          Activity

          dnusbaum Devin Nusbaum added a comment -

          Does the user have Promotion/Promote permission as well? It is not in the same section as the Job/* permissions.

          A screenshot of the permission matrix and of the page with the button that the admin is able to see but the user is not would be helpful.

          ataylor Alex Taylor added a comment -

          Added a permissions matrix which includes Job Promote permission but there is no other "promote" permissions other than artifact promote: Screen Shot 2018-03-30 at 12.02.06 PM.png

           

          Admin user button: Screen Shot 2018-03-30 at 12.03.04 PM.png

           

          Dev user no button: Screen Shot 2018-03-30 at 12.03.39 PM.png

           

          Sorry for not adding that earlier

          dnusbaum Devin Nusbaum added a comment -

          It looks like that is a different permission from some other plugin. Here is the permission that needs to be activated:

          I spoke with the reporter and this appears to be a misconfiguration of some proprietary plugins, so I am closing the ticket. Anyone can reopen the ticket if they see this with an open-source authorization strategy plugin and the Promotion/Promote permission is checked for a non-admin user.


            People

            • Assignee:
              dnusbaum Devin Nusbaum
              Reporter:
              ataylor Alex Taylor
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: