Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51265

Run Result Recorder: Didn't find any test results to record

    Details

    • Similar Issues:

      Description

      When executing HPE tests from file system from a .mtbx, if multiple of the same jobs are running concurrently on the last build in the jenkins job queue will recognize that there are results available from the UFT tests.

       

      Attached is an output of the successfully built job - but failed to report successfully build

       

      Our process is similar to the following:

       

      We execute a master build job that parses a folder for available UFT tests, and kicks off each one as a new job through another build by dynamically creating a mtbx file.

      These jobs run UFT scripts as expected and will always output UFT Run Reports

      During the 'Post-Build Action' for Publishing HPE tests results the RunResultRecorder fails to find any test results to record 

      Subsequently the qTest Plugin will fail to upload a result to our server.

       

      Important thing to note: We cannot use ALM for these parallel job executions

        Attachments

          Activity

          Hide
          gront Daniel Gront added a comment -

          Hey,

          What Jenkins version, plugin version, UFT version are you using?

          Show
          gront Daniel Gront added a comment - Hey, What Jenkins version, plugin version, UFT version are you using?

            People

            • Assignee:
              tamasflorin Tamas Florin
              Reporter:
              whaplescr Charles Whaples
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: