Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51512

Git parameter plugin does not work with Windows agent

    Details

    • Similar Issues:

      Description

      Hi team,

      We are trying to to dynamically fetch a list of Tags or Branches from GitHub in Jenkins. 

      The Git Parameter Plug-in (which is made for this purpose) works when using unix slaves and unix git

      however it fails when configured for Windows (Win-Git) with error mentioned in Screenshot (error.png)

      Our Jenkins Master is Unix 

      Request you to please assist to resolve same.

        Attachments

          Issue Links

            Activity

            Hide
            klimas7 Boguslaw Klimas added a comment -

            Hi,

            I can't reproduce this issue, but I found code smells, which can provide to unexpected behavior. commit: f85678c3 I changed  it in release 0.9.10.

            Additional I changed error handling, please look on wiki page

            If this issue steal occurred in your environment after update the plugin. Please add more information which I can use to reproduce this issue and reopen this issue. 

            Show
            klimas7 Boguslaw Klimas added a comment - Hi, I can't reproduce this issue, but I found code smells, which can provide to unexpected behavior. commit:  f85678c3  I changed  it in release 0.9.10. Additional I changed error handling, please look on  wiki page If this issue steal occurred in your environment after update the plugin. Please add more information which I can use to reproduce this issue and reopen this issue. 
            Hide
            klimas7 Boguslaw Klimas added a comment -

            Release 0.9.10

            Show
            klimas7 Boguslaw Klimas added a comment - Release 0.9.10
            Hide
            mpflugfelder Mike Pflugfelder added a comment -

            I appear to be having the same problem.  I'm relatively new to Jenkins, so I'll help as much as I can.  Our master is Unix and I'm trying to build a project on Windows.  This is our first attempt at building applications via Jenkins on Windows.  It's very possible that my configuration isn't ideal, so I'm open to suggestions as to the best way to configure the client.  What information can I provide to help troubleshoot this issue?

            Show
            mpflugfelder Mike Pflugfelder added a comment - I appear to be having the same problem.  I'm relatively new to Jenkins, so I'll help as much as I can.  Our master is Unix and I'm trying to build a project on Windows.  This is our first attempt at building applications via Jenkins on Windows.  It's very possible that my configuration isn't ideal, so I'm open to suggestions as to the best way to configure the client.  What information can I provide to help troubleshoot this issue?
            Hide
            klimas7 Boguslaw Klimas added a comment -

            Hi,

            I released plugin in version 0.9.11 where this issue was resolved, could you check that and confirm the issue is resolved

             
            Regards
            Boguslaw

            Show
            klimas7 Boguslaw Klimas added a comment - Hi, I released plugin in version 0.9.11 where this issue was resolved, could you check that and confirm the issue is resolved   Regards Boguslaw

              People

              • Assignee:
                klimas7 Boguslaw Klimas
                Reporter:
                gunjanvm Gunjan Mirchandani
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: