Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5155

Link on view containing non-latin characters is broken since hudson 1.339

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP SP2 with language settings set for Russian language,
      Hudson 1.339
    • Similar Issues:
      Show 5 results

      Description

      If I set other than "All" view as default view, link on "All" view will be broken.
      It will be in Russian locale:
      http://localhost/view/%D0%92%00%D1%81%00%D0%B5%00/
      But should be:
      http://localhost/view/%D0%92%D1%81%D0%B5/
      Note that first case has unnecessary zero byte after each 2-byte unicode sequence.

      Noticed after ungrade to 1.339.

      UPDATE:
      Actually if I try to create any view with Russian name, link on it will be incorrect (with unexpected zeroes).

        Attachments

          Activity

          rutsky rutsky created issue -
          rutsky rutsky made changes -
          Field Original Value New Value
          Summary Localized link on "All" view is broken since hudson 1.339 Link on view containing non-latin characters is broken since hudson 1.339
          Description If I set other than "All" view as default view, link on "All" view will be broken.
          It will be in Russian locale:
          http://localhost/view/%D0%92%00%D1%81%00%D0%B5%00/
          But should be:
          http://localhost/view/%D0%92%D1%81%D0%B5/
          Note that first case has unnecessary zero byte after each 2-byte unicode sequence.

          Noticed after ungrade to 1.339.
          If I set other than "All" view as default view, link on "All" view will be broken.
          It will be in Russian locale:
          http://localhost/view/%D0%92%00%D1%81%00%D0%B5%00/
          But should be:
          http://localhost/view/%D0%92%D1%81%D0%B5/
          Note that first case has unnecessary zero byte after each 2-byte unicode sequence.

          Noticed after ungrade to 1.339.

          UPDATE:
          Actually if I try to create any view with Russian name, link on it will be incorrect (with unexpected zeroes).
          rutsky rutsky made changes -
          Environment Hudson 1.339 Windows XP SP2 with language settings set for Russian language,
          Hudson 1.339
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/Util.java
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=25962
          Log:
          [FIXED JENKINS-5155] in 1.342. The root cause of the problem is that the backing byte[] of ByteBuffer can be bigger than the actual current content that's on it — in the case of the reporter he got byte[3] as the backing buffer when only two bytes of it is in use.

          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          abayer Andrew Bayer made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              rutsky rutsky
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: