Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51617

Jenkins outputs multiple "Â" when setting it up with apache reverse proxy

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: In Progress (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.107.3
    • Similar Issues:

      Description

      I've followed documentation how to set up jenkins with apache reverse proxy, and I'm still seeing jenkins with strange characters "Â". In localhost:8080 it shows fine, but when using the apache reverse proxy in https, I got this "Â" all over the place. It seems that it is replacing the space character.

      I have omitted some information for security purposes with XXXXX

      This is my apache configuration:

      default-ssl.conf

      --------------------

      <IfModule mod_ssl.c>
      <VirtualHost default:443>
      LogLevel warn
      ServerName XXXXXXXXXXXXXXXXX
      ErrorLog "|/usr/bin/rotatelogs /var/log/apache2/jenkins/error_log.%Y%m%d 86400"
      CustomLog "|/usr/bin/rotatelogs /var/log/apache2/jenkins/access_log.%Y%m%d 86400" combined

      <Location />
      Order allow,deny
      Allow from all
      </Location>

      <Proxy http://localhost:8080/>
      Order deny,allow
      Allow from all
      </Proxy>

      ProxyRequests Off
      ProxyPreserveHost On
      AllowEncodedSlashes NoDecode

      SetOutputFilter INFLATE;proxy-html;DEFLATE
      ProxyHTMLExtended On
      ProxyPass / http://localhost:8080/ nocanon
      ProxyPassReverse / http://localhost:8080/
      ProxyHTMLURLMap http://localhost:8080/ /
      RequestHeader set X-Forwarded-Proto "https"
      RequestHeader set X-Forwarded-Port "443"

      SSLEngine on
      SSLProtocol all -SSLv2
      SSLCipherSuite HIGH:MEDIUM
      SSLCertificateFile XXXXXXXXXXXXXXXXXXXXXXx
      SSLCertificateChainFile XXXXXXXXXXXXXXXXXXXXXXXXXx
      SSLCertificateKeyFile XXXXXXXXXXXXXXXXXXXXXXXXX
      SetEnvIf User-Agent ".MSIE." nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0

      </VirtualHost>
      </IfModule>

       

      Also, I've tried other configuration options without success:

       

      RewriteEngine On

      RewriteRule ^/(.*)$ http://localhost:8080/$1 [P,NE]

      AddDefaultCharset utf-8

      IndexOptions FancyIndexing VersionSort NameWidth=* HTMLTable +Charset=UTF-8

      ProxyHTMLCharsetOut *

      <Location />

      ...

      ProxyPassReverse /

      RequestHeader unset Accept-Encoding

      </Location>

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              ronaldegmar Ronald Barrios
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: