Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5162

Failed to instantiate TemporarySpaceMonitor and DiskSpaceMonitor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Gentoo Linux
      Sun JDK 1.6.0_17 64bit

      Description

      Hudson 1.339 (clean install)

      I got the forrowing stack trace. Perhaps TemporarySpaceMonitor and DiskSpaceMonitor should have a default constructor.

      — START —
      2009/12/29 21:40:43 hudson.model.ComputerSet createDefaultInstance
      致命的: Failed to instanciate class hudson.node_monitors.TemporarySpaceMonitor
      java.lang.InstantiationException: hudson.node_monitors.TemporarySpaceMonitor
      at java.lang.Class.newInstance0(Class.java:340)
      at java.lang.Class.newInstance(Class.java:308)
      at hudson.model.ComputerSet.createDefaultInstance(ComputerSet.java:381)
      at hudson.model.ComputerSet.(ComputerSet.java:369)
      at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)

      2009/12/29 21:40:43 hudson.model.ComputerSet createDefaultInstance
      致命的: Failed to instanciate class hudson.node_monitors.DiskSpaceMonitor
      java.lang.InstantiationException: hudson.node_monitors.DiskSpaceMonitor
      at java.lang.Class.newInstance0(Class.java:340)
      at java.lang.Class.newInstance(Class.java:308)
      at hudson.model.ComputerSet.createDefaultInstance(ComputerSet.java:381)
      at hudson.model.ComputerSet.(ComputerSet.java:369)
      at hudson.model.LoadStatistics$LoadStatisticsUpdater.doRun(LoadStatistics.java:214)
      at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)

      2009/12/29 21:40:42 hudson.model.DownloadService$Downloadable doPostBack
      情報: Obtained the updated data file for hudson.tasks.Ant.AntInstaller
      — END —

      Steps to reproduce

      1. rm -rf $HUDSON_HOME; mkdir $HUDSON_HOME
      2. java -jar hudson.jar
      3. see Hudson.log

        Activity

        sogabe sogabe created issue -
        ashlux ashlux added a comment -

        Introduced with JENKINS-2552.

        ashlux ashlux added a comment -

        On a fresh install temp space and disk space are not monitored because of this problem. As a workaround, enabling both monitors fixes the problem.

        mdonohue mdonohue made changes -
        Field Original Value New Value
        Summary Failed to instanciate TemporarySpaceMonitor and DiskSpaceMonitor Failed to instantiate TemporarySpaceMonitor and DiskSpaceMonitor
        ashlux ashlux added a comment -

        I've attached a possible fix.

        I'm not seeing a better way to do this without a default constructor. I am more than happy to commit this fix unless someone has a better idea.

        Since I'm new here, I'm going to wait for word before doing anything (and in particular http://wiki.jenkins-ci.org/display/JENKINS/About+Hudson+project says I should discuss changes at first before making them).

        ashlux ashlux made changes -
        Attachment JENKINS-5162.patch [ 18988 ]
        scm_issue_link SCM/JIRA link daemon added a comment -

        Code changed in hudson
        User: : kohsuke
        Path:
        trunk/hudson/main/core/src/main/java/hudson/node_monitors/AbstractDiskSpaceMonitor.java
        trunk/hudson/main/core/src/main/java/hudson/node_monitors/DiskSpaceMonitor.java
        trunk/hudson/main/core/src/main/java/hudson/node_monitors/TemporarySpaceMonitor.java
        trunk/www/changelog.html
        http://fisheye4.cenqua.com/changelog/hudson/?cs=25730
        Log:
        [FIXED JENKINS-5162] in 1.341.

        scm_issue_link SCM/JIRA link daemon made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        sogabe sogabe made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            sogabe sogabe
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: