Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51669

Jenkins POM: "mvn clean deploy" stopped working in Jenkins 2.125+ and (?) Parent POM 1.46 +

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 2.125+
    • Similar Issues:

      Description

      Now it just prints...

      [INFO] --- maven-deploy-plugin:2.7:deploy (default-deploy) @ jenkins-test ---
      [INFO] Skipping artifact deployment
      

      I'd guess it was caused by https://github.com/jenkinsci/pom/commit/2ad60fbf2adcee40636cc522cc000a20c2302c35, investigating

      Deploy operation works well with Weekly 2.124 and below

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Deployment still works for Remoting with the Recent Parent POM. So it's likely something on the core's side

          Show
          oleg_nenashev Oleg Nenashev added a comment - Deployment still works for Remoting with the Recent Parent POM. So it's likely something on the core's side
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          My mistake. The same commit has been already deployed, and it caused confusion

          Show
          oleg_nenashev Oleg Nenashev added a comment - My mistake. The same commit has been already deployed, and it caused confusion

            People

            • Assignee:
              Unassigned
              Reporter:
              oleg_nenashev Oleg Nenashev
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: