Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51776

com.google.inject.CreationException with Sauce OnDemand Plugin 1.175 and later

    Details

    • Type: Bug
    • Status: Reopened (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: sauce-ondemand-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.126
      Sauce OnDemand 1.175
    • Similar Issues:

      Description

      Hey there

      When upgrading from 1.174 to 1.175 or 1.176, we face the following issue when running pipelines that make use of the sauceconnect step:

      hudson.remoting.ProxyException: com.google.inject.CreationException: Unable to create injector, see the following errors:
      1) A just-in-time binding to com.saucelabs.jenkins.pipeline.SauceConnectStep was already configured on a parent injector.
        at org.jenkinsci.plugins.workflow.steps.ContextParameterModule.configure(ContextParameterModule.java:45)
      

      The same pipelines work flawlessly with 1.174 (hence we're sticking to that version for now).

        Attachments

          Activity

          Hide
          agauthiez Alexis Gauthiez added a comment -

          We just upgraded the plugin to 1.176 again and the issue is no longer reproducible. I have no clue about what changed between the previous attempt and this one. Anyway, we're not bothered anymore so I'm closing this ticket.

          Show
          agauthiez Alexis Gauthiez added a comment - We just upgraded the plugin to 1.176 again and the issue is no longer reproducible. I have no clue about what changed between the previous attempt and this one. Anyway, we're not bothered anymore so I'm closing this ticket.
          Hide
          agauthiez Alexis Gauthiez added a comment -

          Actually we re-encountered the issue. We're not sure if it's linked to the plugin version though.

          Show
          agauthiez Alexis Gauthiez added a comment - Actually we re-encountered the issue. We're not sure if it's linked to the plugin version though.
          Hide
          manus manus added a comment - - edited

          This is still an issue today on latest plugin & Jenkins versions.

          It will randomly start happening after a Jenkins restart and will consistently occur until a subsequent restart. This smells like a race condition related to plugin loading at Jenkins startup.

          As there have been very similar issues reported with higher priority, I'm upgrading this to Major for more visibility. (Sorry if it's against etiquette.)

          Show
          manus manus added a comment - - edited This is still an issue today on latest plugin & Jenkins versions. It will randomly start happening after a Jenkins restart and will consistently occur until a subsequent restart. This smells like a race condition related to plugin loading at Jenkins startup. As there have been very similar issues reported with higher priority, I'm upgrading this to Major for more visibility. (Sorry if it's against etiquette.)

            People

            • Assignee:
              yfangsl Yeh Fang
              Reporter:
              agauthiez Alexis Gauthiez
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: