Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51838

P4-Plugin: No polling log if Lightweight checkout option is checked

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: p4-plugin
    • Labels:
    • Environment:
      P4 Plugin: 1.8.10
    • Similar Issues:

      Description

      Hi,

      I am using Jenkinsfile and "Lightweight checkout" option is enabled. "checkout scm" is used in my Jenkinsfile. Unfortunately, I am unable to get the Perforce changes.

      I unchecked the "Lightweight checkout" , checked a test changelist and then I got 2 changes, see below:

      It is really weird, No changes or show 2 changes. I expected to see the 1 changelog populated by "checkout scm" during the build.

      BTW: I have read the help note of "Lightweight checkout":
      however, you will not get any changelogs or polling based on the SCM. (If you use checkout scm during the build, this will populate the changelog and initialize polling.)

        Attachments

          Activity

          jackyim Xuezhong Yan added a comment -

          An alternative way:

          • Jenkinsfile
          • scm.getWorkspace().setSyncID("jenkins-${env.JOB_NAME}".replaceAll('
            /', '-'))
          • Scripts in WebUI
          • workspace: streamSpec(charset: 'none', format: "${p4Client}", syncID: "${p4SyncID}", pinHost: false, streamName: "${perforceStream}"))
          jackyim Xuezhong Yan added a comment -

          Cannot Reproduce on P4 Plugin 1.9.4, hence close this issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              jackyim Xuezhong Yan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: