Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51909

Refusing to marshal net.sf.json.JSONObject for security reasons; see https://jenkins.io/redirect/class-filter/

    Details

    • Similar Issues:

      Description

      Hi, I am doing continuous deployments using DeployHub Deployment tool in my workshop.But Jenkins Job is failed but deployment went successfully. The job has failed due to the below error. Please can anyone advise the below one. I did some work around this issue and noticed that issue with DeployHub plugin , I uninstall DeployHub plugin and ran the job and it wemt good and again install the same plugin and ran the job and it went failed status. I am starting the Jenkins service using the below command "java -Dhudson.remoting.ClassFilter=some.pkg.and.ClassName,some.pkg.and.OtherClassName -jar jenkins.war"
      Logged in to DeployHub as user admin*14:29:52* Deploying application dotnetapplication11 to environment dotnetenv1*14:29:55* Deployment #162 started*14:29:55* IO Exception: java.lang.UnsupportedOperationException: Refusing to marshal net.sf.json.JSONObject for security reasons; see
      https://jenkins.io/redirect/class-filter/
      14:29:55 Build step 'DeployHub Interface' marked build as failure*14:29:56* Finished: FAILURE

        Attachments

          Activity

          Hide
          rama_pokuri Rama Pokuri added a comment -

          Hi, Please can you advise if you have any idea about this issue. 

          Show
          rama_pokuri Rama Pokuri added a comment - Hi, Please can you advise if you have any idea about this issue. 
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Please provide a full stacktrace for this issue

          Show
          oleg_nenashev Oleg Nenashev added a comment - Please provide a full stacktrace for this issue
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Without full stacktrace I cannot confirm anything, but it looks like an issue in https://github.com/jenkinsci/deployhub-plugin

           

          Show
          oleg_nenashev Oleg Nenashev added a comment - Without full stacktrace I cannot confirm anything, but it looks like an issue in https://github.com/jenkinsci/deployhub-plugin  
          Hide
          sbtaylor15 Steve Taylor added a comment -

          This issue has been resolved with DeployHub Plugin version 8.0.13.  End user has confirmed that the fix is working.

          Show
          sbtaylor15 Steve Taylor added a comment - This issue has been resolved with DeployHub Plugin version 8.0.13.  End user has confirmed that the fix is working.
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Thanks Steve Taylor!

          Show
          oleg_nenashev Oleg Nenashev added a comment - Thanks Steve Taylor !

            People

            • Assignee:
              sbtaylor15 Steve Taylor
              Reporter:
              rama_pokuri Rama Pokuri
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: