Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52045

Advanced configuration missing on Configure Global Security

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins 2.121.1
      Active Directory Plugin 2.7
      Jenkins running in Windows Server
    • Similar Issues:

      Description

      I just upgraded from Jenkins 2.107.3 to 2.121.1 along with all the plugins I needed, including Active Directory going from 2.6 to 2.7. The Advanced configuration button is no longer present. Since this upgrade also triggers TLS Configuration is not correct and TLS is hidden by said button, I cannot use this version of the plugin.

        Attachments

          Issue Links

            Activity

            Hide
            fbelzunc Félix Belzunce Arcos added a comment -

            Nick JonesKen Rachynski

            • Would you mind to check this snapshot to confirm all the issues are fixed?
            Show
            fbelzunc Félix Belzunce Arcos added a comment - Nick Jones Ken Rachynski Would you mind to check this snapshot to confirm all the issues are fixed? active-directory.hpi
            Hide
            medianick Nick Jones added a comment -

            Félix Belzunce Arcos, I've installed the 2.8-SNAPSHOT build and am not seeing the warning banner anymore. The only change I see in the system config is simply the expected plugin version in the <securityRealm> element. So, I'm good to go. Thanks!

            Show
            medianick Nick Jones added a comment - Félix Belzunce Arcos , I've installed the 2.8-SNAPSHOT build and am not seeing the warning banner anymore. The only change I see in the system config is simply the expected plugin version in the <securityRealm> element. So, I'm good to go. Thanks!
            Hide
            fbelzunc Félix Belzunce Arcos added a comment -

            Ken Rachynski Would you mind to test, please? I think that will fix the problem - I will submit then a PR and release.

            Show
            fbelzunc Félix Belzunce Arcos added a comment - Ken Rachynski Would you mind to test, please? I think that will fix the problem - I will submit then a PR and release.
            Hide
            krachynski Ken Rachynski added a comment -

            I apologize for the delay. Yes, this snapshot appears to address all of my issues. I now have the advanced section back and all my users and groups are validated properly.

            Show
            krachynski Ken Rachynski added a comment - I apologize for the delay. Yes, this snapshot appears to address all of my issues. I now have the advanced section back and all my users and groups are validated properly.
            Hide
            fbelzunc Félix Belzunce Arcos added a comment -

            This should be fixed in https://github.com/jenkinsci/active-directory-plugin/pull/85 - and it is being released as active-directory-2.8

            Show
            fbelzunc Félix Belzunce Arcos added a comment - This should be fixed in https://github.com/jenkinsci/active-directory-plugin/pull/85 - and it is being released as active-directory-2.8

              People

              • Assignee:
                fbelzunc Félix Belzunce Arcos
                Reporter:
                krachynski Ken Rachynski
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: