Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52051

git-parameter exec: nc: not found.

    Details

    • Type: Bug
    • Status: Reopened (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: git-parameter-plugin
    • Labels:
    • Environment:
      master: Ubuntu 14.04, Agents: Ubuntu 14.04, CentOS 7.5, SLES-12SP2
      Jenkins 2.128, git-parameter 0.9.2
    • Similar Issues:

      Description

      Occasionally not getting a list of tags for build with parameters.
      The jenkins.log has this message:

      WARNING: [ project-release ] Download tags from the repository failed
      hudson.plugins.git.GitException: Command "git ls-remote -t ssh://gerrit.example.com:29418/group/project v18.*" returned status code 128:
      stdout:
      stderr: /bin/bash: line 0: exec: nc: not found
      ssh_exchange_identification: Connection closed by remote host
      fatal: Could not read from remote repository.
      
      Please make sure you have the correct access rights
      and the repository exists
      

      .
      On the CentOS 7.5 system, nc is at /usr/bin.

       nc --help
      Ncat 7.50 ( https://nmap.org/ncat )
      

      On the other systems, nc is at /bin and nc reports:

       nc -h
      OpenBSD netcat (Debian patchlevel 1.105-7ubuntu1)
      This is nc from the netcat-openbsd package. An alternative nc is available
      in the netcat-traditional package.
      
      jemalmbe@coral-sles12-1:~> nc -h
      OpenBSD netcat (SUSE Linux)
      This is nc from the netcat-openbsd package. An alternative nc is available
      in the netcat-traditional package.
      

      The access to the git repository is through ssh and the git repository is working.
      If I configure a default tag value in the git parameter, that is used for building.
      But when this happens, I have no way to automatically build the top tag sorted from the list by default.

        Attachments

          Issue Links

            Activity

            wb8tyw John Malmberg created issue -
            klimas7 Boguslaw Klimas made changes -
            Field Original Value New Value
            Labels ssh_error
            klimas7 Boguslaw Klimas made changes -
            Link This issue duplicates JENKINS-45480 [ JENKINS-45480 ]
            klimas7 Boguslaw Klimas added a comment -

            Hi,

            I can't reproduce this issue, but I found code smells, which can provide to unexpected behavior. commit: f85678c3 I changed  it in release 0.9.10.

            Additional I changed error handling, please look on wiki page

            If this issue steal occurred in your environment after update the plugin. Please add more information which I can use to reproduce this issue and reopen this issue. 

            klimas7 Boguslaw Klimas added a comment -

            Release 0.9.10

            klimas7 Boguslaw Klimas made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Cannot Reproduce [ 5 ]
            wb8tyw John Malmberg added a comment -

            I will try to verify this week.

            The issue appears to be that the code was looking only for "/usr/bin/nc", and on the systems where the plugin was failing for me, the path needed is "/bin/nc".

            So it should have been easy to reproduce by temporary moving nc to /bin/nc on a test system.

            wb8tyw John Malmberg added a comment - - edited

            It is still failing to find the releases when using Ubuntu or SLESS/(Open SUSE Leap) build agents.

            It is generating a different message in the log.

            WARNING: [ argobots-release ]  Download tags from the repository failed
            hudson.plugins.git.GitException: Command "git ls-remote -t ssh://review.example.com:29418/daos/argobots v1" returned status code 128:
            stdout:
            stderr: Permission denied (publickey).
            fatal: Could not read from remote repository.
            

            The repository is access via a SSH-AGENT supplied credentials.

            wb8tyw John Malmberg made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            wb8tyw John Malmberg added a comment -

            Except for the error message, the behavior seems to be the same. It is only working if the build agent is running CentOS,
            It is not working if the build agent is running Ubuntu 14.04, or SLES 12SP2.

            wb8tyw John Malmberg added a comment -

            Changing the repository entry to have the ssh credentials with it did not change the behavior.

            klimas7 Boguslaw Klimas added a comment -

            Hi,

            I released plugin in version 0.9.11 where this issue was resolved, could you check that and confirm the issue is resolved

             
            Regards
            Boguslaw

            klimas7 Boguslaw Klimas made changes -
            Link This issue relates to JENKINS-56558 [ JENKINS-56558 ]
            klimas7 Boguslaw Klimas made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            wb8tyw John Malmberg added a comment -

            Still not working.
            Only change is now nothing is logged to the /var/log/jenkins/log on failure.

            Did you try reproducing this by temporarily moving where the nc command is located on the build agent?
            That is what I see different on the for the distros where it works and does not work, and that also goes along with the original bug report.

            wb8tyw John Malmberg added a comment -

            Still not working.

            wb8tyw John Malmberg made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]

              People

              • Assignee:
                klimas7 Boguslaw Klimas
                Reporter:
                wb8tyw John Malmberg
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: