Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52060

Credentials issue: Access for user 'nouser' has not been enabled by 'p4 protect'.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: p4-plugin
    • Labels:
    • Environment:
      Jenkins ver. 2.86, Windows, P4 1.8.5
    • Similar Issues:

      Description

      I'm trying to add a Perforce Password Credential to connect to a remote replica server but I'm having issues connecting. I'm using an SSL connection and have confirmed the credentials work and triple checked I am using the correct fingerprint. 

      When I hit "Test Connection" it spins for a short while then spits out "Server Connection Error.".

      From looking at the system logs I see this error which seems to indicate it is trying to connect with the username "nouser" though this is not the username that I have entered.

       

      Jun 20, 2018 5:14:35 AM SEVERE org.jenkinsci.plugins.p4.client.ConnectionHelper connect
      P4: Unable to connect: com.perforce.p4java.exception.ConnectionException: Access for user 'nouser' has not been enabled by 'p4 protect'.
      
      Jun 20, 2018 5:14:35 AM INFO org.jenkinsci.plugins.p4.client.ConnectionHelper 
      P4: Unable to connect: com.perforce.p4java.exception.ConnectionException: Access for user 'nouser' has not been enabled by 'p4 protect'.
      Jun 20, 2018 5:14:35 AM SEVERE org.jenkinsci.plugins.p4.client.ConnectionHelper connectionRetry
      P4: Connection retry: 1
      Jun 20, 2018 5:14:35 AM INFO org.jenkinsci.plugins.p4.client.ConnectionHelper 
      P4: Connection retry: 1
      Jun 20, 2018 5:14:38 AM SEVERE org.jenkinsci.plugins.p4.client.ConnectionHelper connectionRetry
      P4: Connection retry giving up...
      Jun 20, 2018 5:14:38 AM INFO org.jenkinsci.plugins.p4.client.ConnectionHelper 
      P4: Connection retry giving up...
      
      

      Any idea why this would happen? Connections to our own Perforce servers are connecting fine. 

       

        Attachments

          Activity

          alexgeek Alexander Perry added a comment -

          From some digging a colleague did, part of the issue seems to be caused by our Jenkins master and the nodes having P4CHARSET set to utf8 but this external server is not using utf8. 

          p4karl Karl Wirth added a comment -

          Hi Alexander Perry did you solve this problem or did you just avoid using the remote server?

          p4karl Karl Wirth added a comment -

          Closing for now. Happy to reopen if this becomes an issue again.


            People

            • Assignee:
              p4karl Karl Wirth
              Reporter:
              alexgeek Alexander Perry
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: