Details

    • Type: New Feature
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None
    • Similar Issues:

      Description

      I think it is a good idea to have the chance, after a user cancel a running job to run a special build step for cleaning up. it work like java swing window closing, that you can start a action when a user want to close a window. or like try/catch constructions.
      to use this, you can make a new feature at the job config page with a after job buildstep, like the normal build steps.

      My Problem and the father of the idea:
      we start during our build a virtual machine with the test enviroment. than we test in this virtual machine. our full test run over 3 hours and so sometimes user break up the build to run the next build.
      explaination: we have more types of this build but not enough computer power to run much of this jobs with a virtual machine parralel. so we must allowed to break the jobs.
      the problem is, the virtual machine is still up running and the next jobs have sometimes problems with the running virtual machine. so i want, when a user break a build, that a post build step is stopping the virtual machine.

      i think, this option can also use other users for make there builds more robust. so i am very happy, when it is easy to create this feature. or when it is easy to realize, where i must start investigation for changing the source code.

        Attachments

          Activity

          mdonohue mdonohue added a comment -

          This would be a nice feature for the downstream-ext plugin. I don't think there is a component for it in Jira yet though.

          kutzi kutzi added a comment -

          I think that I've not fully understood your use-case - have you taken a look at the http://wiki.jenkins-ci.org/display/JENKINS/M2+Extra+Steps+Plugin or http://wiki.jenkins-ci.org/display/JENKINS/Batch+Task+Plugin if they can help you?
          IMO this sounds more like a build-cleanup step which belongs into the same job and not into another job which is triggered when the job is aborted.

          However, as there seems to be no way to do this in Hudson currently, I'll take a look at it. Should be easy to implement.

          tobiasnebel TobiasNebel added a comment -

          1. The Plugin M2 Extra Steps looks nice, but i have a ANT Project and no Maven at the Hudson Server. So i think i didnt work.
          2. The Batch Task Plugin look also good, but the batchs doesnt run automatic after a aborted build.

          >> IMO this sounds more like a build-cleanup step which belongs into the same job and not into another job which is triggered when the job is aborted.
          this is nearly what i want. in my case it works best if the clean up task/step/job start every time, when the job runs ok, run unstable or aborted. but only start the clean up task/step/job when the job is aborted is also ok, because when a job runs ok or unstable all my implemented ant taks run.

          kutzi kutzi added a comment -

          Integrated in downstream-ext 1.3

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kutzi
          Path:
          trunk/hudson/plugins/downstream-ext/src/main/java/hudson/plugins/downstream_ext/DownstreamDependency.java
          trunk/hudson/plugins/downstream-ext/src/main/java/hudson/plugins/downstream_ext/DownstreamTrigger.java
          trunk/hudson/plugins/downstream-ext/src/main/resources/hudson/plugins/downstream_ext/DownstreamTrigger/config.jelly
          trunk/hudson/plugins/downstream-ext/src/main/resources/hudson/plugins/downstream_ext/DownstreamTrigger/config_de.properties
          trunk/hudson/plugins/downstream-ext/src/main/resources/hudson/plugins/downstream_ext/Messages.properties
          trunk/hudson/plugins/downstream-ext/src/main/resources/hudson/plugins/downstream_ext/Messages_de.properties
          http://jenkins-ci.org/commit/26306
          Log:
          JENKINS-5215 allow triggering also for ABORTED builds. Also allows triggering if result is below or equal or equal the specified threshold

          tobiasnebel TobiasNebel added a comment -

          thanks a lot for the new feature. it works fine

          tobiasnebel TobiasNebel added a comment -

          For me the fixing works fine, so close.


            People

            • Assignee:
              kutzi kutzi
              Reporter:
              tobiasnebel TobiasNebel
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: