Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52187

Pipeline: Support. Integrate JBoss Remoting patches in the common release

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      workflow-support 3.0

      Description

      In order to release the Experimental Java 10+ support, we need to have a Pipeline: Support patch available at least in the Experimental Update Center.

      CC Sam Van Oort

        Attachments

          Issue Links

            Activity

            Show
            oleg_nenashev Oleg Nenashev added a comment - https://github.com/jenkinsci/workflow-support-plugin/pull/68    
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            I will try to implement a workaround for it for Java 11 preview availability: JENKINS-51998 . But we will still need a solution for GA, and it does not look to be "just upstreaming" due to the compatibility issues discovered by Sam Van Oort

             

            Show
            oleg_nenashev Oleg Nenashev added a comment - I will try to implement a workaround for it for Java 11 preview availability:  JENKINS-51998 . But we will still need a solution for GA, and it does not look to be "just upstreaming" due to the compatibility issues discovered by Sam Van Oort  
            Hide
            batmat Baptiste Mathus added a comment -

            Oleg Nenashev is this ticket for the long-term fix, or the workaround we already have? If the latter, should it be closed?

            Show
            batmat Baptiste Mathus added a comment - Oleg Nenashev is this ticket for the long-term fix, or the workaround we already have? If the latter, should it be closed?
            Hide
            dnusbaum Devin Nusbaum added a comment - - edited

            Version 3.0 of Pipeline Supporting APIs Plugin was just released, which is compatible with both Java 8 and Java 9+.

            Show
            dnusbaum Devin Nusbaum added a comment - - edited Version 3.0 of Pipeline Supporting APIs Plugin was just released, which is compatible with both Java 8 and Java 9+.

              People

              • Assignee:
                svanoort Sam Van Oort
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: