Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52277

Blueocean doesn't show more than one artifact with the same name

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: blueocean-plugin
    • Labels:
    • Environment:
      Jenkins v2.121.1 with Blueocean v1.5.0 (the "jenkinsci/blueocean:latest" docker image from a couple of weeks ago)

      Plugins: Copy Artifact Plugin v1.39
      OS: CentOS 6.9
      Browsers: Firefox 60 & Chrome 67
    • Similar Issues:
    • Released As:
      Blue Ocean 1.7.0

      Description

      The Blueocean GUI doesn't show artifacts if they have the same name as another artifact. For example, the classic Jenkins UI might show the following artifacts:

      • tests/1/results.xml
      • tests/2/results.xml
      • tests/3/results.xml
      • stuff.txt

      However, Blueocean will only show one of the "results.xml" artifacts:

      • tests/3/results.xml
      • stuff.txt

      The artifacts all exist and can be downloaded via the classic UI. It's quite easy to reproduce by just having some files with the same name and archiving them via a line similar to:

      archiveArtifacts artifacts: "tests/**/results.xml", fingerprint: true

       

       

        Attachments

          Activity

          dragonq Adam Godbeer added a comment -

          Just tested Blue Ocean 1.7.0 and this issue seems to be fixed.


            People

            • Assignee:
              Unassigned
              Reporter:
              dragonq Adam Godbeer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: