Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1704

workflow-job hpi is not available -- install-plugins.sh fails

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: update-center
    • Labels:
      None
    • Similar Issues:

      Description

      I ran the following as part of a Dockerfile based on the Jenkins lts image:

      /usr/local/bin/install-plugins.sh copyartifact job-dsl lockable-resources mercurial workflow-aggregator pipeline-utility-steps configuration-as-code:experimental

      It started failing about 30 minutes ago (saying workflow-job could not be retrieved, after a lot of curl retries that failed with a 404). If you look at the list of files in https://updates.jenkins.io/2.121/latest/ , you can see workflow-job.hpi there. Trying to access the actual file http://archives.jenkins-ci.org/plugins/workflow-job/2.23/workflow-job.hpi fails with a 404 error.

      (I wanted to flag this under website or infrastructure, but I couldn't find a matching component, which is why I filed it under core. Apologies if that's the wrong place.)

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          > Apologies if that's the wrong place.

          No worries, updated the ticket

          danielbeck Daniel Beck added a comment -

          Cannot reproduce, probably an outdated mirror.


            People

            • Assignee:
              Unassigned
              Reporter:
              mathiasdm Mathias De Maré
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: