Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52826

Clicking Configure on a worker created by GCE Plugin results in an error

    Details

    • Similar Issues:

      Description

      After a worker has been spun up via the GCE Plugin, clicking the "Configure" link on the worker page results in an error. Snippet of stack trace is below. Full version is attached.

       

      org.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-2.121.2.jar!/hudson/model/Computer/configure.jelly:43:71: <st:include> No page found 'configure-entries.jelly' for class com.google.jenkins.plugins.computeengine.ComputeEngineInstanceorg.apache.commons.jelly.JellyTagException: jar:file:/var/jenkins_home/war/WEB-INF/lib/jenkins-core-2.121.2.jar!/hudson/model/Computer/configure.jelly:43:71: <st:include> No page found 'configure-entries.jelly' for class com.google.jenkins.plugins.computeengine.ComputeEngineInstance at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:124) at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269) at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95) at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99) at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91) at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)

       

      Worker Status page

       

       

      Worker Configure page

       

        Attachments

          Activity

          arash arash m created issue -
          evanbrown Evan Brown made changes -
          Field Original Value New Value
          Assignee Evan Brown [ evanbrown ] Rachel Yen [ zombiemoose ]
          zombiemoose Rachel Yen added a comment -

          Hi Arash,

          Can you include more details about how you set this up? (Kind of boot image, etc). Can you verify you were successful in adding your cloud/worker instance when you clicked configure?

          zombiemoose Rachel Yen added a comment -

          Hi Arash,

          I was able to reproduce the error and am working on a fix. However, we will most likely not allow workers to be configured while running a build/job.

           

          zombiemoose Rachel Yen added a comment -

          I have since made a commit and release that will have a view only form when you click configure on a worker: https://github.com/jenkinsci/google-compute-engine-plugin/commit/d1fb62c825d8fd6b50ce8f65804b91e46a5e682a

          Closing this issue. Feel free to reopen if there's any concerns.

          zombiemoose Rachel Yen added a comment -

          Added a view only form.

          zombiemoose Rachel Yen made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Released As https://github.com/jenkinsci/google-compute-engine-plugin/releases/tag/google-compute-engine-1.0.5
          sce_hb Simon Elliott added a comment -

          sorry to re-open but i am getting this same issue in Google Compute Engine Plugin V 2.0.0

          org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-2.150.3.jar!/hudson/model/ComputerSet/_new.jelly:41:95: <st:include> No page found 'configure-entries.jelly' for class com.google.jenkins.plugins.computeengine.ComputeEngineInstance
          
          zombiemoose Rachel Yen added a comment -

          That's strange, I do not get that result when I configure for my instance. Can you explain what steps you took?

           

          Also, we're not allowing configuring workers at the moment.

          sce_hb Simon Elliott added a comment -

          its a fresh install. 

          i installed the plugin and tried to add a worker. I then added the credentials config in the documentation and tried again, which also failed. 

          if you are not allowing it currently, what other methods can i use to configure GCE agents?

          zombiemoose Rachel Yen added a comment -

          Are you not configuring the workers through the instance configuration under /configure?

           

          Example: https://cloud.google.com/solutions/using-jenkins-for-distributed-builds-on-compute-engine#configure_jenkins_instance_configurations

          sce_hb Simon Elliott added a comment -

          Hi Rachel, thanks for your response. I hadn't completed the setup int hat area, no. I have now and can confirm i still get the below error when trying to add an agent under Manage Nodes. 

           

          org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-2.150.3.jar!/hudson/model/ComputerSet/_new.jelly:41:95: <st:include> No page found 'configure-entries.jelly' for class com.google.jenkins.plugins.computeengine.ComputeEngineInstance

          however the Node i configured under /configure does now appear as a build agent. I will experiment more tomorrow. 
          Thanks for your help!

          zombiemoose Rachel Yen added a comment -

          O I see. Usually if you just start a job we will provision the nodes for you, but I've now seen a couple of users follow that work flow so perhaps this is worth investigating.

          sce_hb Simon Elliott added a comment -

          Yeah so functionally its OK, i've added 2 "clouds" from /configure and they work as expected. its just when going to Nodes - New Node - Google Compute Engine does it error out. 

          this imo is the instinctive path to follow, if not the correct one..


            People

            • Assignee:
              zombiemoose Rachel Yen
              Reporter:
              arash arash m
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: