Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5286

1.340 fails on first call through browser with exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows 2003 server
    • Similar Issues:

      Description

      Exception page shows

      Jan 14, 2010 11:39:11 PM org.apache.catalina.core.StandardWrapperValve invoke
      SEVERE: Servlet.service() for servlet Stapler threw exception
      java.lang.IllegalAccessError: tried to access method hudson.scm.ChangeLogSet$Entry.setParent(Lhudson/scm/ChangeLogSet;)V from class hudson.scm.CVSChangeLogSet

      ... (see attachments for details)

        Attachments

        1. catalina.2010-01-15.log
          134 kB
        2. catalina.log
          19 kB
        3. localhost.2010-01-14.log
          11 kB
        4. localhost.2010-01-15.log
          210 kB

          Issue Links

            Activity

            Hide
            subbaer subbaer added a comment - - edited

            Updated CVS plugin (found JENKINS-5251) with old hudson 1.337 installation, upgraded to 1.340 and still fails (see localhost.2010-01-15.log).
            Added updated catalina.2010-01-15.log as well.

            Strange - after downgrading to 1.337 again the plugin manager shows again CVS plugin 0.1 instead of 1.0 as installed version??
            Might be a local problem with our storage system. Cannot clarify at the moment.

            Show
            subbaer subbaer added a comment - - edited Updated CVS plugin (found JENKINS-5251 ) with old hudson 1.337 installation, upgraded to 1.340 and still fails (see localhost.2010-01-15.log). Added updated catalina.2010-01-15.log as well. Strange - after downgrading to 1.337 again the plugin manager shows again CVS plugin 0.1 instead of 1.0 as installed version?? Might be a local problem with our storage system. Cannot clarify at the moment.
            Hide
            mindless Alan Harder added a comment -

            A combination of issues is making this harder to fix in your install.. yes, CVS plugin 1.0 has the fix.. however, another issue (JENKINS-3662, fixed in 1.341) may be preventing you from updating the CVS plugin.
            Try this:

            1. update to 1.340
            2. touch $HUDSON_HOME/plugins/cvs.hpi.pinned
            3. use plugin manager to update to CVS 1.0
            Show
            mindless Alan Harder added a comment - A combination of issues is making this harder to fix in your install.. yes, CVS plugin 1.0 has the fix.. however, another issue ( JENKINS-3662 , fixed in 1.341) may be preventing you from updating the CVS plugin. Try this: update to 1.340 touch $HUDSON_HOME/plugins/cvs.hpi.pinned use plugin manager to update to CVS 1.0
            Hide
            subbaer subbaer added a comment -

            Didn't work for me:

            • updated to 1.340 and got exception
            • created cvs.hpi.pinned and restarted tomcat, received exception again.

            I think I'll wait for hudson 1.341 and downgrade again to 1.337

            Show
            subbaer subbaer added a comment - Didn't work for me: updated to 1.340 and got exception created cvs.hpi.pinned and restarted tomcat, received exception again. I think I'll wait for hudson 1.341 and downgrade again to 1.337
            Hide
            subbaer subbaer added a comment -

            Works for me as of 1.341

            Show
            subbaer subbaer added a comment - Works for me as of 1.341

              People

              • Assignee:
                Unassigned
                Reporter:
                subbaer subbaer
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: