Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53233

Unable to run Performance Test in Jenkins - executeRequest exception: Operation failed. Error code: 1001

    Details

    • Similar Issues:

      Description

      I am unable to run a performance test via Jenkins.  I keep on getting the following message when I try to run a test:

      Test description: HP PC Test via Jenkins
      Validating parameters before run
      OK
      Trying to login
      [PCServer='http://SSS.com', User='SSS']
      Login succeeded

      Executing Load Test:
      ====================
      Test ID: 122
      Test Instance ID: 2401
      Timeslot Duration: 0:30(h:mm)
      Post Run Action: Collate and Analyze
      Use VUDS: false
      ====================

      Error: executeRequest exception: Operation failed. Error code: 1001
      Error: Run could not start!
      Logout succeeded
      Empty Results
      Result Status: UNSTABLE

      • - -
        Build step 'Execute performance test using Performance Center' changed build result to UNSTABLE
        No results xml File provided
        Finished: UNSTABLE

       

      When I try to run the test in HP Performance Center 12.53, everything is fine.  The test completes and I am able to view results.  But when I start it in Jenkins it fails with error executeRequest exception: Operation failed. Error code: 1001

       

      I hope you guys can help me with this.

       

      Your response is highly appreciated.

       

      Thanks in Advance!

        Attachments

          Activity

          Hide
          ml580k Mark Laurora added a comment -

          Hello Experts,

           

          Good day!

           

          Can someone help us with this please?  We are currently doing a Proof of Concept for the integration of HPE Performance Center and Jenkins and unable to move on.

           

          I hope someone can help us with this please?

           

          Your response is highly appreciated.

           

          Thanks in Advance!

           

           

          Show
          ml580k Mark Laurora added a comment - Hello Experts,   Good day!   Can someone help us with this please?  We are currently doing a Proof of Concept for the integration of HPE Performance Center and Jenkins and unable to move on.   I hope someone can help us with this please?   Your response is highly appreciated.   Thanks in Advance!    
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          From the log you sent, it could be a permission problem.
          The first operation performed after login is looking for all test instances existing for the specific test configured to be run. If this operation fails (normally, the search should provide a list of test instances, even empty, but it could be failing in case of lack of permission), the entire operation is aborted. So try to verify if the Performance Center credentials provided in the configuration is enough.
          Regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, From the log you sent, it could be a permission problem. The first operation performed after login is looking for all test instances existing for the specific test configured to be run. If this operation fails (normally, the search should provide a list of test instances, even empty, but it could be failing in case of lack of permission), the entire operation is aborted. So try to verify if the Performance Center credentials provided in the configuration is enough. Regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          Hi Daniel,

          Thank you for your inputs.  Unfortunately, I don't think this is a permission issue. My account is setup as Administrator on both Jenkins and HPE Performance Center so I should be able to do anything in the tools. Do you have any other suggestions Sir? If needed, I can setup a Skype Meeting for us to discuss further.

          Should you need any other information please let me know.

           

          Thanks and Regards,

          Mark Anthony Laurora

          Show
          ml580k Mark Laurora added a comment - Hi Daniel, Thank you for your inputs.  Unfortunately, I don't think this is a permission issue. My account is setup as Administrator on both Jenkins and HPE Performance Center so I should be able to do anything in the tools. Do you have any other suggestions Sir? If needed, I can setup a Skype Meeting for us to discuss further. Should you need any other information please let me know.   Thanks and Regards, Mark Anthony Laurora
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          I have surrounded the operation trying to retrieve the list of test instances by exception handling that will ignore the failure. This means that a new test instance will be created for the test each time you try to run the build.
          I made a local build and uploaded the hpi file to this reported issue as attachment spitted in two files (you will need both files to extract the hpi file).
          For uploading the plugin to Jira, you can go to Jenkins home -> Manage Jenkins -> Manage Plugins -> Advanced tab -> and use the Upload Plugin section to upload the hpi file. you might need to restart Jenkins and also recreate the build step from scratch.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, I have surrounded the operation trying to retrieve the list of test instances by exception handling that will ignore the failure. This means that a new test instance will be created for the test each time you try to run the build. I made a local build and uploaded the hpi file to this reported issue as attachment spitted in two files (you will need both files to extract the hpi file). For uploading the plugin to Jira, you can go to Jenkins home -> Manage Jenkins -> Manage Plugins -> Advanced tab -> and use the Upload Plugin section to upload the hpi file. you might need to restart Jenkins and also recreate the build step from scratch. regards, Daniel
          Hide
          danieldanan Daniel Danan added a comment -

          hi Mark,
          I reuploaded new files. If you didn't download them yet, don't pay attention to this update. Otherwise, please re-download them and try them instead of the previous one (which will not display the build step in the configuration).
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - hi Mark, I reuploaded new files. If you didn't download them yet, don't pay attention to this update. Otherwise, please re-download them and try them instead of the previous one (which will not display the build step in the configuration). regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          Hi Daniel,

          Thank you so much for looking into this.  Unfortunately, I am unable to open/extract the file. Do I need to install another tool in order for me to extract the hpi file I need? Is it possible if you can compress the file into a normal .zip folder please?

          Thanks and Regards,

          Mark Anthony Laurora

          Show
          ml580k Mark Laurora added a comment - Hi Daniel, Thank you so much for looking into this.  Unfortunately, I am unable to open/extract the file. Do I need to install another tool in order for me to extract the hpi file I need? Is it possible if you can compress the file into a normal .zip folder please? Thanks and Regards, Mark Anthony Laurora
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Marc,
          I used 7zip for compressing the file.
          I am attaching splitted zip files this time, try them.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Marc, I used 7zip for compressing the file. I am attaching splitted zip files this time, try them. regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          Hi Daniel,

          I finally installed the Plugin in our Jenkins. However, I am encountering the Login Failure when I try to run the Job:

          Building in workspace /var/lib/jenkins/workspace/HPE PC Jenkins Integration
          Thu 2018 Sep 06 at 16:27:10.621 PM UTC - plugin version is '5.5.1-beta-SNAPSHOT'
          Thu 2018 Sep 06 at 16:27:10.621 PM UTC - Test description: Jenkins PC Integration
          Thu 2018 Sep 06 at 16:27:10.622 PM UTC - Validating parameters before run
          Thu 2018 Sep 06 at 16:27:10.622 PM UTC - OK
          Thu 2018 Sep 06 at 16:27:10.623 PM UTC - java.lang.NullPointerException
          Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Login failed
          Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Empty Results
          Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Result Status: FAILURE

           

          It appears that the Plugin you sent would not allow me to enter my own HP PC Credentials during setup.  Please see attached file named as HPPC - Jenkins Integration.

           

          Kindly let me know what should I do next.

           

          I appreciate you looking into this Daniel.  Thank you in Advance!

          Show
          ml580k Mark Laurora added a comment - Hi Daniel, I finally installed the Plugin in our Jenkins. However, I am encountering the Login Failure when I try to run the Job: Building in workspace /var/lib/jenkins/workspace/HPE PC Jenkins Integration Thu 2018 Sep 06 at 16:27:10.621 PM UTC - plugin version is '5.5.1-beta-SNAPSHOT' Thu 2018 Sep 06 at 16:27:10.621 PM UTC - Test description: Jenkins PC Integration Thu 2018 Sep 06 at 16:27:10.622 PM UTC - Validating parameters before run Thu 2018 Sep 06 at 16:27:10.622 PM UTC - OK Thu 2018 Sep 06 at 16:27:10.623 PM UTC - java.lang.NullPointerException Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Login failed Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Empty Results Thu 2018 Sep 06 at 16:27:10.623 PM UTC - Result Status: FAILURE   It appears that the Plugin you sent would not allow me to enter my own HP PC Credentials during setup.  Please see attached file named as HPPC - Jenkins Integration.   Kindly let me know what should I do next.   I appreciate you looking into this Daniel.  Thank you in Advance!
          Hide
          danieldanan Daniel Danan added a comment -

          hi Marc,
          It looks like the plugin is having troubles to retrieve the credentials.
          I am adding some additional logs in the code area of the retrieving the credentials and uploading new hpi. Please use it and send me the logs.
          I would also suggest you to verify if the configuration was save correctly (after saving the configuration, are you able to see the same values when reopening it again)?
          Regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - hi Marc, It looks like the plugin is having troubles to retrieve the credentials. I am adding some additional logs in the code area of the retrieving the credentials and uploading new hpi. Please use it and send me the logs. I would also suggest you to verify if the configuration was save correctly (after saving the configuration, are you able to see the same values when reopening it again)? Regards, Daniel
          Hide
          danieldanan Daniel Danan added a comment -

          hi Marc,
          Unfortunately, I will be ooo during the next days (I'll be back for Wednesday 12th and then off again). I'll be happy to continue when i am back.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - hi Marc, Unfortunately, I will be ooo during the next days (I'll be back for Wednesday 12th and then off again). I'll be happy to continue when i am back. regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          I still got the same error message Daniel:

          Building in workspace /var/lib/jenkins/workspace/HPE PC Jenkins Integration
          credentialsId is null
          Thu 2018 Sep 06 at 18:19:04.687 PM UTC - plugin version is '5.5.1-beta-SNAPSHOT'
          Thu 2018 Sep 06 at 18:19:04.688 PM UTC - Test description: PC Jenkins Integration
          Thu 2018 Sep 06 at 18:19:04.688 PM UTC - Validating parameters before run
          Thu 2018 Sep 06 at 18:19:04.688 PM UTC - OK
          credentialsId =
          Thu 2018 Sep 06 at 18:19:04.689 PM UTC - java.lang.NullPointerException
          Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Login failed
          Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Empty Results
          Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Result Status: FAILURE

          • - -
            Build step 'Execute performance test using Performance Center' changed build result to FAILURE
            Recording test results
            RunResultRecorder: didn't find any test results to record
            Finished: FAILURE

           

          ... and the plugin still does not allow me to enter my HP PC Credentials.  The first time I installed the plugin it allowed me to setup my own HP PC Account as credentials, but now, when I used the plugin you provided, it does not allow me to set the credentials manually.  Now it only shows a dropdown which does not contain the correct credentials needed to login to our instance of HPE Performance Center:

           

           

          Show
          ml580k Mark Laurora added a comment - I still got the same error message Daniel: Building in workspace /var/lib/jenkins/workspace/HPE PC Jenkins Integration credentialsId is null Thu 2018 Sep 06 at 18:19:04.687 PM UTC - plugin version is '5.5.1-beta-SNAPSHOT' Thu 2018 Sep 06 at 18:19:04.688 PM UTC - Test description: PC Jenkins Integration Thu 2018 Sep 06 at 18:19:04.688 PM UTC - Validating parameters before run Thu 2018 Sep 06 at 18:19:04.688 PM UTC - OK credentialsId = Thu 2018 Sep 06 at 18:19:04.689 PM UTC - java.lang.NullPointerException Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Login failed Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Empty Results Thu 2018 Sep 06 at 18:19:04.689 PM UTC - Result Status: FAILURE - - Build step 'Execute performance test using Performance Center' changed build result to FAILURE Recording test results RunResultRecorder: didn't find any test results to record Finished: FAILURE   ... and the plugin still does not allow me to enter my HP PC Credentials.  The first time I installed the plugin it allowed me to setup my own HP PC Account as credentials, but now, when I used the plugin you provided, it does not allow me to set the credentials manually.  Now it only shows a dropdown which does not contain the correct credentials needed to login to our instance of HPE Performance Center:    
          Hide
          ml580k Mark Laurora added a comment -

          Oh by the way, regarding your inputs:

          "I would also suggest you to verify if the configuration was save correctly (after saving the configuration, are you able to see the same values when reopening it again)?" - Yes the configurations were saved.  I was able to see the same values I inputted when I opened it again.

           

          About you being Out of Office, that is okay Sir.  I am Out of office myself starting tomorrow and will be back on Monday.
           

           

          Show
          ml580k Mark Laurora added a comment - Oh by the way, regarding your inputs: "I would also suggest you to verify if the configuration was save correctly (after saving the configuration, are you able to see the same values when reopening it again)?" - Yes the configurations were saved.  I was able to see the same values I inputted when I opened it again.   About you being Out of Office, that is okay Sir.  I am Out of office myself starting tomorrow and will be back on Monday.    
          Hide
          ml580k Mark Laurora added a comment -

          Hi Daniel, Good day to you!

          I hope you had a good vacation.

          I am sorry to keep bugging you on this but will you be able to give me an update please?

          Your response is highly appreciated.

           

          Thanks in Advance! 

           

           

          Show
          ml580k Mark Laurora added a comment - Hi Daniel, Good day to you! I hope you had a good vacation. I am sorry to keep bugging you on this but will you be able to give me an update please? Your response is highly appreciated.   Thanks in Advance!     
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          Please keep bugging me as much you need, i am very happy to help and I will do everything needed so this integration works properly in your environment.
          Also excuse my lack of response during this period of time as i am in a period of time in which I am mostly out of the office and partially returning to work when i can (I will be ooo for two days, back on Thursday only and then I will be ooo again during next week).
          I would like you to use a plugin I am developing in which I have integrated the functionality allowing to run tests as this is my current working platform of work. This plugin will contain two step build types. one for syncing performance scripts from Git to PC and you can ignore it (it is being QA and documented) and one allowing to run test which is named "Run performance test using Performance Center". Please use the last one and provide similar input when configuring the job in Jenkins. If you need documentation, use the documentation specified here: https://wiki.jenkins.io/display/JENKINS/MICRO+FOCUS+Application+Automation+Tools and not the one from the helps (some new fields are not yet documented).
          You will find this plugin compressed to two spitted files and upload to this Jenkins issue as attachment.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, Please keep bugging me as much you need, i am very happy to help and I will do everything needed so this integration works properly in your environment. Also excuse my lack of response during this period of time as i am in a period of time in which I am mostly out of the office and partially returning to work when i can (I will be ooo for two days, back on Thursday only and then I will be ooo again during next week). I would like you to use a plugin I am developing in which I have integrated the functionality allowing to run tests as this is my current working platform of work. This plugin will contain two step build types. one for syncing performance scripts from Git to PC and you can ignore it (it is being QA and documented) and one allowing to run test which is named "Run performance test using Performance Center". Please use the last one and provide similar input when configuring the job in Jenkins. If you need documentation, use the documentation specified here: https://wiki.jenkins.io/display/JENKINS/MICRO+FOCUS+Application+Automation+Tools and not the one from the helps (some new fields are not yet documented). You will find this plugin compressed to two spitted files and upload to this Jenkins issue as attachment. regards, Daniel
          Hide
          danieldanan Daniel Danan added a comment -

          The uploaded files are named micro-focus-performance-center-integration.z01 and micro-focus-performance-center-integration.zip.

          Show
          danieldanan Daniel Danan added a comment - The uploaded files are named micro-focus-performance-center-integration.z01 and micro-focus-performance-center-integration.zip.
          Hide
          ml580k Mark Laurora added a comment -

          Thank you for your response Daniel.  I appreciate your assistance on this very much!

          I have installed the plugin you have shared.  I was finally able to login however, I keep on seeing this errors in the Console Output:

           

          Please let me know what else I can do about this issue.

          Your response is highly appreciated.

           

          Show
          ml580k Mark Laurora added a comment - Thank you for your response Daniel.  I appreciate your assistance on this very much! I have installed the plugin you have shared.  I was finally able to login however, I keep on seeing this errors in the Console Output:   Please let me know what else I can do about this issue. Your response is highly appreciated.  
          Hide
          ml580k Mark Laurora added a comment -

          Also, on the Post-build Actions section > expand the Add post-build action drop-down, I cannot seem to find the Publish test result.

          Show
          ml580k Mark Laurora added a comment - Also, on the  Post-build Actions  section > expand the  Add post-build action  drop-down, I cannot seem to find the  Publish test result .
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          The error in the first screenshot seems to be caused by a problem in Performance Center side. I would be happy to take a look at your PC server, perhaps the logs can pinpoint the reason of PC failing to start the test.
          Regarding the second screenshot, the last plugin I sent you does not have the "add post-build action", it only exists in the original plugin.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, The error in the first screenshot seems to be caused by a problem in Performance Center side. I would be happy to take a look at your PC server, perhaps the logs can pinpoint the reason of PC failing to start the test. Regarding the second screenshot, the last plugin I sent you does not have the "add post-build action", it only exists in the original plugin. regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          Thank you for your response Daniel.  We can have a webex session for you to be able to look into our HP PC Server.  I am available at around 2PM Eastern Time onwards.  Kindly send the webex/skype detials to mark.a.p.laurora@accenture.com and I will attend.

          Show
          ml580k Mark Laurora added a comment - Thank you for your response Daniel.  We can have a webex session for you to be able to look into our HP PC Server.  I am available at around 2PM Eastern Time onwards.  Kindly send the webex/skype detials to mark.a.p.laurora@accenture.com  and I will attend.
          Hide
          ml580k Mark Laurora added a comment -

          Hi Daniel,

          Good day to you!

          I am sorry to bug you again but I would like to follow up on this please?  I hope you can give me an update.  We can have a webex session for you to be able to look into our HP PC Server.  I am available at around 2PM Eastern Time onwards.  Kindly send the webex/skype detials to mark.a.p.laurora@accenture.com and I will make myself available.

          Show
          ml580k Mark Laurora added a comment - Hi Daniel, Good day to you! I am sorry to bug you again but I would like to follow up on this please?  I hope you can give me an update.  We can have a webex session for you to be able to look into our HP PC Server.  I am available at around 2PM Eastern Time onwards.  Kindly send the webex/skype detials to  mark.a.p.laurora@accenture.com  and I will make myself available.
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          Sorry for the late answer. I just came back from vacation.
          I'll be happy to have a Skype meeting with you if you can and review the problem from Performance Center side as it may come from something wrong there and not necessarily from the plugin. I am available today so just send me a message notifying me of your availability when you can.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, Sorry for the late answer. I just came back from vacation. I'll be happy to have a Skype meeting with you if you can and review the problem from Performance Center side as it may come from something wrong there and not necessarily from the plugin. I am available today so just send me a message notifying me of your availability when you can. regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          I am glad you are back Daniel.

          I am available at around 3PM Eastern Time onwards.  Kindly send the webex/skype detials and I will make myself available for our call.

          Show
          ml580k Mark Laurora added a comment - I am glad you are back Daniel. I am available at around 3PM Eastern Time onwards.  Kindly send the webex/skype detials and I will make myself available for our call.
          Hide
          danieldanan Daniel Danan added a comment -

          Hi Mark,
          Unfortunately, this is too late for me as I am based in Israel and 15:00 Eastern time will be 20:00 Israel time (I like working late but not that late ).
          I suggest we meet tomorrow (Tuesday) sometime in the morning or very early afternoon for you so it is not too late for me.
          regards,
          Daniel

          Show
          danieldanan Daniel Danan added a comment - Hi Mark, Unfortunately, this is too late for me as I am based in Israel and 15:00 Eastern time will be 20:00 Israel time (I like working late but not that late ). I suggest we meet tomorrow (Tuesday) sometime in the morning or very early afternoon for you so it is not too late for me. regards, Daniel
          Hide
          ml580k Mark Laurora added a comment -

          I am sorry Daniel, I did not know you are based in Israel.  Does 11 AM Eastern work for you Sir?

          Show
          ml580k Mark Laurora added a comment - I am sorry Daniel, I did not know you are based in Israel.  Does 11 AM Eastern work for you Sir?

            People

            • Assignee:
              danieldanan Daniel Danan
              Reporter:
              ml580k Mark Laurora
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: