Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53311

[Blue Ocean] Sequential stages appear to be completed but are still executing

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      We have a visualisation problem in new "Sequential Stages".
      In some cases, sequential stages get a green check mark and appear to be completed even though they are still executing.
      Minimal pipeline example:

      pipeline {
      agent any
           stages {
              stage('Parallel') {
                  failFast false
                  parallel {
                      stage('Nested B') {
                          stages {
                              stage('Nested B-1') {
                                  steps {
                                      echo 'Nested A-1'
                                  }
                              }
                              stage('Nested B-2') {
                                  steps {
                                      sleep time: 5, unit: 'MINUTES'
                                  }
                              }
                          }
                      }
                      stage('Nested C') {
                          when {
                              expression { false == true }
                          }
                          stages {
                              stage('Nested C-1') {
                                  steps {
                                      echo 'Nested C-1'                               
                                  }
                              }
                              stage('Nested C-2') {
                                  steps {
                                      echo 'Nested C-2'                               
                                  }
                              }
                          }
                      }
                      stage('Nested A') {
                          steps {
                              sleep time: 5, unit: 'MINUTES'
                          }
                      }
                  }
              }
          }
      }
      

        Attachments

          Issue Links

            Activity

            zakharovdi Denis Zakharov created issue -
            zakharovdi Denis Zakharov made changes -
            Field Original Value New Value
            Epic Link JENKINS-43953 [ 181485 ]
            zakharovdi Denis Zakharov made changes -
            Description We have a visualisation problem in new "Sequential Stages".
            Stage likes completed when it is executed.
            Minimal pipeline example:
            pipeline {
            agent any
                 stages {
                    stage('Parallel') {
                        failFast false
                        parallel {
                            stage('Nested B') {
                                stages {
                                    stage('Nested B-1') {
                                        steps {
                                            echo 'Nested A-1'
                                        }
                                    }
                                    stage('Nested B-2') {
                                        steps {
                                            sleep time: 5, unit: 'MINUTES'
                                        }
                                    }
                                }
                            }
                            stage('Nested C') {
                                when {
                                    expression { false == true }
                                }
                                stages {
                                    stage('Nested C-1') {
                                        steps {
                                            echo 'Nested C-1'
                                        }
                                    }
                                    stage('Nested C-2') {
                                        steps {
                                            echo 'Nested C-2'
                                        }
                                    }
                                }
                            }
                            stage('Nested A') {
                                steps {
                                    sleep time: 5, unit: 'MINUTES'
                                }
                            }
                        }
                    }
                }
            }
            We have a visualisation problem in new "Sequential Stages".
            Stage likes completed when it is executed.
            Minimal pipeline example:
            {code:java}
            pipeline {
            agent any
                 stages {
                    stage('Parallel') {
                        failFast false
                        parallel {
                            stage('Nested B') {
                                stages {
                                    stage('Nested B-1') {
                                        steps {
                                            echo 'Nested A-1'
                                        }
                                    }
                                    stage('Nested B-2') {
                                        steps {
                                            sleep time: 5, unit: 'MINUTES'
                                        }
                                    }
                                }
                            }
                            stage('Nested C') {
                                when {
                                    expression { false == true }
                                }
                                stages {
                                    stage('Nested C-1') {
                                        steps {
                                            echo 'Nested C-1'
                                        }
                                    }
                                    stage('Nested C-2') {
                                        steps {
                                            echo 'Nested C-2'
                                        }
                                    }
                                }
                            }
                            stage('Nested A') {
                                steps {
                                    sleep time: 5, unit: 'MINUTES'
                                }
                            }
                        }
                    }
                }
            }
            {code}
            dnusbaum Devin Nusbaum made changes -
            dnusbaum Devin Nusbaum added a comment -

            I spent a few minutes reproducing this today. It looks like a legitimate bug. I will update the title and description to make them a little clearer. Here is the most minimal test case I could come up with:

            pipeline {
                agent any
                stages {
                    stage('Parallel') {
                        parallel {
                            stage('Nested A') {
                                steps {
                                    echo 'A'
                                }
                            }
                            stage('Nested B') {
                                stages {
                                    stage('Nested B-1') {
                                        steps {
                                            sleep time: 1, unit: 'MINUTES'
                                        }
                                    }
                                }
                            }
                        }
                    }
                }
            }
            

            And here is a screenshot that showing that Nested B-1 has a green check mark even though it is still executing:

            dnusbaum Devin Nusbaum made changes -
            Summary [Blue Ocean] New sequential stage likes completed when it is executed [Blue Ocean] Sequential stages appear to be completed but are still executing
            dnusbaum Devin Nusbaum made changes -
            Description We have a visualisation problem in new "Sequential Stages".
            Stage likes completed when it is executed.
            Minimal pipeline example:
            {code:java}
            pipeline {
            agent any
                 stages {
                    stage('Parallel') {
                        failFast false
                        parallel {
                            stage('Nested B') {
                                stages {
                                    stage('Nested B-1') {
                                        steps {
                                            echo 'Nested A-1'
                                        }
                                    }
                                    stage('Nested B-2') {
                                        steps {
                                            sleep time: 5, unit: 'MINUTES'
                                        }
                                    }
                                }
                            }
                            stage('Nested C') {
                                when {
                                    expression { false == true }
                                }
                                stages {
                                    stage('Nested C-1') {
                                        steps {
                                            echo 'Nested C-1'
                                        }
                                    }
                                    stage('Nested C-2') {
                                        steps {
                                            echo 'Nested C-2'
                                        }
                                    }
                                }
                            }
                            stage('Nested A') {
                                steps {
                                    sleep time: 5, unit: 'MINUTES'
                                }
                            }
                        }
                    }
                }
            }
            {code}
            We have a visualisation problem in new "Sequential Stages".
            In some cases, sequential stages get a green check mark and appear to be completed even though they are still executing.
            Minimal pipeline example:
            {code:java}
            pipeline {
            agent any
                 stages {
                    stage('Parallel') {
                        failFast false
                        parallel {
                            stage('Nested B') {
                                stages {
                                    stage('Nested B-1') {
                                        steps {
                                            echo 'Nested A-1'
                                        }
                                    }
                                    stage('Nested B-2') {
                                        steps {
                                            sleep time: 5, unit: 'MINUTES'
                                        }
                                    }
                                }
                            }
                            stage('Nested C') {
                                when {
                                    expression { false == true }
                                }
                                stages {
                                    stage('Nested C-1') {
                                        steps {
                                            echo 'Nested C-1'
                                        }
                                    }
                                    stage('Nested C-2') {
                                        steps {
                                            echo 'Nested C-2'
                                        }
                                    }
                                }
                            }
                            stage('Nested A') {
                                steps {
                                    sleep time: 5, unit: 'MINUTES'
                                }
                            }
                        }
                    }
                }
            }
            {code}
            dnusbaum Devin Nusbaum made changes -
            Labels pipeline windows pipeline
            olamy Olivier Lamy made changes -
            Assignee Olivier Lamy [ olamy ]
            olamy Olivier Lamy added a comment -

            weird as the parent node ('Nested B') has correct status RUNNING but not 'Nested B-1'.

            olamy Olivier Lamy made changes -
            Link This issue is duplicated by JENKINS-53587 [ JENKINS-53587 ]
            olamy Olivier Lamy made changes -
            Link This issue is duplicated by JENKINS-53555 [ JENKINS-53555 ]
            henryborchers Henry Borchers made changes -
            Assignee Olivier Lamy [ olamy ] Henry Borchers [ henryborchers ]
            henryborchers Henry Borchers made changes -
            Assignee Henry Borchers [ henryborchers ]
            henryborchers Henry Borchers added a comment -

            sorry, i accidentally clicked assign to me.  didn't mean to and I'm not sure how to revert to the original setting

            henryborchers Henry Borchers made changes -
            Assignee Olivier Lamy [ olamy ]
            olamy Olivier Lamy made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            olamy Olivier Lamy made changes -
            Status In Progress [ 3 ] Fixed but Unreleased [ 10203 ]
            Resolution Fixed [ 1 ]
            olamy Olivier Lamy made changes -
            Link This issue is duplicated by JENKINS-53129 [ JENKINS-53129 ]
            zakharovdi Denis Zakharov added a comment -

            Thank you for nice work, Olivier. Can we get it in 1.8.x?

            trane9991 Taras Postument added a comment -

            Fix seems to be released in 1.8.3 but I can't say it fixes the issue for me.

            Sometimes steps status displayed correctly and sometimes it shows that no steps are running at all.

             

            Also, it seems like on the UI if I select the running step I can't see its details.

            olamy Olivier Lamy added a comment -

            Taras Postument please open an other issue and provide some screenshot/logs or anything to reproduce the issue....

            trane9991 Taras Postument added a comment -

            Olivier Lamy I will once I gather more info. It seems too random for me now

            olamy Olivier Lamy made changes -
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
            hasselmm Mathias Hasselmann made changes -
            Link This issue relates to JENKINS-53547 [ JENKINS-53547 ]
            olamy Olivier Lamy made changes -
            Link This issue is duplicated by JENKINS-53547 [ JENKINS-53547 ]
            dnusbaum Devin Nusbaum made changes -
            Link This issue relates to JENKINS-53816 [ JENKINS-53816 ]

              People

              • Assignee:
                olamy Olivier Lamy
                Reporter:
                zakharovdi Denis Zakharov
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: