Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53342

agent went offline after jenkins instance restart

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
    • Environment:
      windows
    • Similar Issues:

      Description

      Hello,

      I am using jenkins v2.105 and jre 1.8

      I am using Linux as master and IBM AIX and windows server 2K12 as slaves. we are executing nightly builds on both slaves, yesterday i have restarted Jenkins instance after that agent which are configured on windows through JNLP went offline and not coming online. below is the error it's showing on windows, anybody has any workaround for this issue then please let me know.

       

      Aug 29, 2018 1:43:04 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Locating server among http://x.x.x.x:x/jenkins/
      Aug 29, 2018 1:43:04 PM org.jenkinsci.remoting.engine.JnlpAgentEndpointResolver resolve
      INFO: Remoting server accepts the following protocols: [JNLP4-connect, Ping]
      Aug 29, 2018 1:43:04 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Agent discovery successful
        Agent address: x.x.x.x
        Agent port:    37091
        Identity:      51:a8:0d:a8:18:dd:db:d8:ea:18:b7:98:da:76:b2:ae
      Aug 29, 2018 1:43:04 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Handshaking
      Aug 29, 2018 1:43:04 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to x.x.x.x:37091
      Aug 29, 2018 1:43:35 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to x.x.x.x:37091 (retrying:2)
      java.io.IOException: Failed to connect to x.x.x.x:37091
       at org.jenkinsci.remoting.engine.JnlpAgentEndpoint.open(JnlpAgentEndpoint.java:242)
       at hudson.remoting.Engine.connect(Engine.java:686)
       at hudson.remoting.Engine.innerRun(Engine.java:547)
       at hudson.remoting.Engine.run(Engine.java:469)
      Caused by: java.net.ConnectException: Connection timed out: connect
       at sun.nio.ch.Net.connect0(Native Method)
       at sun.nio.ch.Net.connect(Unknown Source)
       at sun.nio.ch.Net.connect(Unknown Source)
       at sun.nio.ch.SocketChannelImpl.connect(Unknown Source)
       at java.nio.channels.SocketChannel.open(Unknown Source)
       at org.jenkinsci.remoting.engine.JnlpAgentEndpoint.open(JnlpAgentEndpoint.java:203)
       ... 3 more

       

      Could you please help me out here?

      just replaced master IP with x.x.x.x.

      Thanks in advance.

        Attachments

          Activity

          jthompson Jeff Thompson added a comment -

          Are you seeing this on multiple agents or just a single one?

          If it is a single one, you should investigate the configuration and network connectivity from that one machine to the master. There is likely something that changed in its configuration or networking. You could try manually verifying connectivity.

          If you see it on multiple agents, then you could investigate the settings on the master. Consider common configurations or behaviors among the agents that experience the problem.

          There isn't enough information provided for anyone else to be able to diagnose or reproduce this issue. 

          This presentation contains further information on diagnosing Remoting connectivity issues. You might be able to find some information in there useful for your troubleshooting exercise. https://speakerdeck.com/onenashev/day-of-jenkins-2017-dealing-with-agent-connectivity-issues

          jthompson Jeff Thompson added a comment -

          As there hasn't been any response on this for a long time, there is insufficient information to reproduce, and responses were provided to the submitter I'm going to close this out. Please re-open if you can provide sufficient information.


            People

            • Assignee:
              jthompson Jeff Thompson
              Reporter:
              shrapm shraddha Magar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: