Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5342

UCM ClearCase polling: no change detected even though changes have occurred

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: clearcase-plugin
    • Labels:
      None
    • Environment:
      OS: Windows XP
    • Similar Issues:

      Description

      Hello,

      I am currently using Hudson 1.341 and ClearCase plugin 1.1.1.

      My job configuration is as follows (I have attached the full config.xml, and paste here what I guess is most relevant):
      <scm class="hudson.plugins.clearcase.ClearCaseUcmSCM">
      <viewName>stromp_be_builc</viewName>
      <excludedRegions></excludedRegions>
      <loadRules>\be_rec\config\
      \be_rec\access\
      \be_rec\admins\
      \be_rec\be\
      \be_rec\buildservices\
      \be_rec\uf\
      \be_rec\sef\
      \be_rec\jwash\</loadRules>
      <useDynamicView>false</useDynamicView>
      </scm>

      The last UCM ClearCase access logs looks something like:

      Started on Jan 21, 2010 10:26:57 AM
      [stromp_be_builc] $ cleartool pwv -root
      D:\java\hudson\jobs\stromp_be_test\workspace\stromp_be_builc
      [stromp_be_builc] $ cleartool lshistory -all -since 20-jan-10.10:21:30utc+0000 -fmt '\"%Nd\" \"%u\" \"%En\" \"%Vn\" \"%e\" \"%o\" \"%[activity]p\" \n%c\n' -branch brtype:jcp_v13.1_be_int -nco be_rec\config\ be_rec\access\ be_rec\admins\ be_rec\be\ be_rec\buildservices\ be_rec\uf\ be_rec\sef\ be_rec\jwash\
      "20100120.114845" "lmiguet" "D:\java\hudson\jobs\stromp_be_test\workspace\stromp_be_builc\be_rec\be\airshopper\legacy\src\main\java\com\amadeus\ocg\standard\business\farecommon\entity\PricingCommandOutput.java" "\main\jcp_v13.1_be_int\4" "create version" "checkin" "PTR3693254_WWW_AeRE_V131_INTCR_3313592-_Code_Review"

      Done. Took 4.7 sec
      No changes

      I had a look at issue 3666 (http://issues.jenkins-ci.org/browse/JENKINS-3666) and it looks very similar to the one I am currently having.

      Do you have any idea of why this happens? Is there a config issue on my job?

      Thanks in advance for your help,

      S├ębastien Tromp

        Attachments

          Issue Links

            Activity

            daedin daedin added a comment -

            Configuration of my job.

            abayer Andrew Bayer added a comment -

            The problem is caused by your load rules ending in slashes/backslashes - we append slashes/backslashes to each load rule in the regular expression we use to determine whether a file in the lshistory output is under one of the load rules. I'll have a fix for this in 1.1.2, but in the meantime, you can just remove the trailing slashes/backslashes (yeah, I can never remember which are slashes and which are backslashes) from your load rules and you should be fine.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java
            https://hudson.dev.java.net/source/browse/hudson/trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java?view=diff&rev=26188&p1=trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java&p2=trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java&r1=26187&r2=26188
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMDummy.java
            https://hudson.dev.java.net/source/browse/hudson/trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMDummy.java?view=auto&rev=26188
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java
            https://hudson.dev.java.net/source/browse/hudson/trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java?view=diff&rev=26188&p1=trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java&p2=trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java&r1=26187&r2=26188
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmHistoryActionTest.java
            https://hudson.dev.java.net/source/browse/hudson/trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmHistoryActionTest.java?view=diff&rev=26188&p1=trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmHistoryActionTest.java&p2=trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmHistoryActionTest.java&r1=26187&r2=26188
            http://jenkins-ci.org/commit/26188
            Log:
            [FIXED JENKINS-5342] Load rules ending in slash or backslash were never matching against checkins from lshistory - fixed and added test for this as well as changes to ClearCaseUcmSCMDummy for use in other tests

            daedin daedin added a comment -

            Removing the slashes (guess these are normal slashes?) indeed solves my issue.
            Thanks!


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                daedin daedin
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: